W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API naming

From: Charles McCathieNevile <chaals@opera.com>
Date: Fri, 26 Jan 2007 18:12:35 -0500
To: "Simon Pieters" <zcorpan@gmail.com>, João Eiras <joao.eiras@gmail.com>
Cc: "Web APIs WG" <public-webapi@w3.org>
Message-ID: <op.tmsaq9gawxe0ny@30-5-51.wireless.csail.mit.edu>

On Fri, 26 Jan 2007 17:52:09 -0500, Simon Pieters <zcorpan@gmail.com>  

> A way to reduce the number of typos might be to drop the trailing "s" 
> from both method names. It's equally clear what it does IMHO.

We could do that.

> Of the two getElementListBySelector and getElementsBySelector, thepeople  
> I've spoken to seem to prefer getElementsBySelector.

OK. In order to make that useful feedback, can you say how many people and  
they are? With comments like this, it is hard to know if you are one of  
people all saying the same thing as they talk to each other, or someone
representing some process that had 3% of professional Web Developers in  
who decided to take a binding vote on their preferred outcome...

>> The reason for GetElementListBySelectors and not getElementsBySelectors 
>> was to make it moderately clear and give people a better chance of
>> debugging quickly.
> Although if API consistency is desireable then "getElementListBy..." 
> doesn't seem to appear anywhere as far as I can tell.

Obviously it is a change. My feeling is that it isn't as radical a change  
as the
alternatives proposed, and that the clear visual difference was valuable  
to justify it. Your mileage may vary, of course.



Charles McCathieNevile, Opera Software: Standards Group
hablo español - je parle français - jeg lærer norsk
chaals@opera.com Try Opera 9.1 http://opera.com
Received on Friday, 26 January 2007 23:12:41 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC