W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API naming

From: Simon Pieters <zcorpan@gmail.com>
Date: Fri, 26 Jan 2007 12:34:28 +0100
To: João Eiras <joao.eiras@gmail.com>
Cc: "Web APIs WG" <public-webapi@w3.org>
Message-ID: <op.tmrefqq17a8kvn@hp-a0a83fcd39d2>

Hi,

On Fri, 26 Jan 2007 06:26:14 +0100, João Eiras <joao.eiras@gmail.com>  
wrote:

>> Robert Sayre gave my permission to quote him from IRC:
>>> [20:48] <sayrer> wow, annevk
>>> [20:48] <sayrer> those names suck!
>>> [21:02] <zcorpan> sayrer: what names?
>>> [21:02] <sayrer> getElementsListBySelector
>>> [...]
>>> [21:03] * zcorpan likes get and getAll better
>>> [21:03] * sayrer notes that I got it wrong
>>
>
> Again, this is personal taste. I could say the same for any other name.

Please note though that Robert typoed the method name. Aditionally, I  
typoed it too when creating a poll at SitePoint Forums to see what they  
think:

    http://www.sitepoint.com/forums/showthread.php?t=454192

...and that typo really wasn't intentional just to prove a point. It is  
easily typoed and I think that is a serious problem.

Regards,
-- 
Simon Pieters
Received on Friday, 26 January 2007 11:34:37 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT