W3C home > Mailing lists > Public > public-webapi@w3.org > January 2007

Re: Selectors API updates

From: Robin Berjon <robin@berjon.com>
Date: Wed, 10 Jan 2007 11:06:20 +0100
Message-Id: <A204A009-EE2B-49F8-9F34-669995057FC5@berjon.com>
Cc: "Web API WG (public)" <public-webapi@w3.org>
To: Anne van Kesteren <annevk@opera.com>

On Jan 09, 2007, at 23:08, Anne van Kesteren wrote:
> I updated the Selectors API specification today and added  
> equivalent methods for element nodes. It didn't make much sense to  
> me to postpone this.
> I resolved the naming debate by going for:
> * Document.get()
> * Document.getAll()
> * Element.get()
> * Element.getAll()
> These names are short, don't clash with autocomplete and provide a  
> superset of the functionality given by the other get* methods.

Sorry, I don't wish to reopen the naming debate, but these really  
don't strike me as the ones closest to consensus (aside from being  
dreadful picks). I think there are a bunch of names that people don't  
like but can live with, these are just pure nonsense. I certainly  
know that while I would have dropped the ball on any number of bad  
options, if these stay in the draft I will request formal objection  
from my AC Rep.

Robin Berjon - http://berjon.com/
In which level of metalanguage are you now speaking?
Received on Wednesday, 10 January 2007 14:10:27 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC