W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Hallvord R. M. Steen <hallvord@opera.com>
Date: Thu, 21 Dec 2006 09:29:59 +0100
To: "Anne van Kesteren" <annevk@opera.com>, "Dave Massy" <Dave.Massy@microsoft.com>, "Web API WG (public)" <public-webapi@w3.org>
Cc: "Chris Wilson" <chris.wilson@microsoft.com>, "Tina Duff" <tinad@microsoft.com>
Message-ID: <op.tkwhv9nea3v5gv@hr-opera.oslo.opera.com>

On Tue, 19 Dec 2006 21:50:44 +0100, Anne van Kesteren <annevk@opera.com>  

>> getElementBySelector/getElementsBySelector is the only proposal we  
>> think is acceptable.
> But it's not accurate. This also creates the problem Ian Hickson pointed  
> out a few times. That people will map it to $$ or something which makes  
> it even less useful.

People will do that anyway for obfuscation/convenience/wrapper function  
features/compatibility layers and similar reasons. I don't really see that  
as a problem.

"getElementsByTagName" is annoying but it's mostly because of that extra  
capitalised N. My vote would be consistency with the other DOM functions  
and thus getElement(s)BySelector .

Hallvord R. M. Steen
Core QA JavaScript tester, Opera Software
Opera - simply the best Internet experience
Received on Thursday, 21 December 2006 08:29:51 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC