W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Doug Schepers <doug@schepers.cc>
Date: Wed, 20 Dec 2006 16:59:17 -0500
Message-ID: <4589B235.2000306@schepers.cc>
To: Jon Ferraiolo <jferrai@us.ibm.com>
Cc: Dave Massy <Dave.Massy@microsoft.com>, Web API public <public-webapi@w3.org>

As do I.  Descriptive names are useful.


Jon Ferraiolo wrote:
> I agree with the Microsoft folks on this thread.
> Jon
> Jon Ferraiolo <jferrai@us.ibm.com>
> Web Architect, Emerging Technologies
> IBM, Menlo Park, CA
> Mobile: +1-650-926-5865
>              Dave Massy                                                    
>              <Dave.Massy@micro                                             
>              soft.com>                                                  To 
>              Sent by:                  Charles McCathieNevile              
>              public-webapi-req         <chaals@opera.com>, Web API public  
>              uest@w3.org               <public-webapi@w3.org>              
>                                                                         cc 
>                                        Chris Wilson                        
>              12/19/2006 12:35          <chris.wilson@microsoft.com>, Anne  
>              PM                        van Kesteren <annevk@opera.com>,    
>                                        Tina Duff <tinad@microsoft.com>     
>                                                                    Subject 
>                                        RE: Selectors API naming            
> 1. Other Issues.
> It'd be great to have more detail and scenario on NSResolver. It appears to
> allow elements within the document to have different prefixes than things
> in the style sheet. For example if we map html as the prefix for XHTML in
> our document then we’d write it like:
> <html:table><html:tr><html:td></html:td></html:tr></html:table>
> But then we can write a selector such as:
>              “h|table > h|tr > h|td”
> With a NSResolver that maps h to the same namespace as the html in the
> primary document. This seems potentially confusing.
> As I mentioned previously a more complete example of staticNodeList usage
> would also be appreciated.
> 2. Naming
> getElementBySelector/getElementsBySelector is the only proposal we think is
> acceptable. match/matchAll is not appropriate for a specific DOM method and
> matchSelector/matchAllSelectors isn't really much of an improvement.
> I'm concerned the group appears to believe naming is not important based on
> the belief that there is no such thing as the perfect name. While it is
> probably true that there is no such thing as a perfect name we have to
> think about the lives of web developers and the challenges they face. For
> these people consistent naming helps them find their way around the APIs
> and have some idea of what to expect from them. Members of this group may
> be fine with naming something xabcdexy() but I'm not sure that this group
> is really representative of the average web developer.
> I'm more than familiar with "shipping is a feature" :) but shipping the
> right thing at the right quality level is also important. We do believe the
> functionality outlined in this spec is useful and want it to move forward
> as quickly as it can. However we also want to ensure it is clear, easy to
> use and easy to understand.
> Thanks
> -Dave
> -----Original Message-----
> From: Charles McCathieNevile [mailto:chaals@opera.com]
> Sent: Tuesday, December 19, 2006 8:52 AM
> To: Web API public
> Cc: Chris Wilson; Dave Massy; Anne van Kesteren
> Subject: Re: Selectors API naming
> OK folks,
> Let's get this in perspective. We are trying to publish this document as a
> last call, and get on with the dozen other documents we are meant to get
> done in the next year. So I have two questions I would like answers on:
> 1. Does anyone see any other issue in the current draft that should be
> fixed?
> 2. For the following options, do you consider the names "fine", "not great
> but acceptable", or "unacceptable"?
>       getElementBySelector/getElementsBySelector
>       match/matchAll
>       matchSelector/matchAllSelectors
>     If and Only If you consider all 3 names are so bad as to be
> unacceptable, please propose an alternative.
> While getting naming perfect is a great thing, I don't know of it ever
> being done before. "Shipping is a feature", as a friend who was a product
> manager at a Redmond-based software company used to remind me, and if we
> can't get nomenclative perfection then I suggest we at least enhance the
> "shipping" side of our feature list...
> cheers
> Chaals (wearing a slightly ill-fitting chair's hat)
> --
>    Charles McCathieNevile, Opera Software: Standards Group
>    hablo español  -  je parle français  -  jeg lærer norsk
> chaals@opera.com          Try Opera 9 now! http://opera.com
Received on Wednesday, 20 December 2006 21:59:49 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC