W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Robert Sayre <sayrer@gmail.com>
Date: Wed, 20 Dec 2006 13:32:26 -0500
Message-ID: <68fba5c50612201032v49f1eb26ua83c8f89180c5de7@mail.gmail.com>
To: "Jim Ley" <jim@jibbering.com>
Cc: "Chris Wilson" <Chris.Wilson@microsoft.com>, "Ian Hickson" <ian@hixie.ch>, "Dave Massy" <dave.massy@microsoft.com>, "Anne van Kesteren" <annevk@opera.com>, "Web API WG (public)" <public-webapi@w3.org>

On 12/20/06, Jim Ley <jim@jibbering.com> wrote:
> Not that I'm overly energised with naming, but...
...
>
> I agree with this view entirely.  getSomething is a pattern worth keeping
> for developer sanity.

JS programmers use short names for these things. Like $() instead of
getElementById. The names in the draft look fine to me. I like my
fingers, and I don't like autocomplete :)

-- 

Robert Sayre
Received on Wednesday, 20 December 2006 18:32:38 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT