W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Jim Ley <jim@jibbering.com>
Date: Wed, 20 Dec 2006 18:24:03 -0000
Message-ID: <00d001c72464$0725b630$0302a8c0@Sniff>
To: "Chris Wilson" <Chris.Wilson@microsoft.com>, "Ian Hickson" <ian@hixie.ch>
Cc: "Dave Massy" <dave.massy@microsoft.com>, "Anne van Kesteren" <annevk@opera.com>, "Web API WG \(public\)" <public-webapi@w3.org>

"Chris Wilson" <Chris.Wilson@microsoft.com>

Not that I'm overly energised with naming, but...

>As Martijn said, I believe people will map document.matchAll almost as
>often to $$ as document.getElementsBySelector - so I'd much rather stick
>with the pattern, and presume that if developers want to map to a()
>they'll do it.

I agree with this view entirely.  getSomething is a pattern worth keeping 
for developer sanity.

>>existing functionality, "document.all". Would "select()" be ok with
>Actually, I'd presume "document.select()" would select the document
>itself into some context (e.g., it would activate the document, make its
>tab the selected one, etc.).

I agree with this too, .select() is too much like .focus() and gives in mind 
completely different class of functionality.


Received on Wednesday, 20 December 2006 18:25:06 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC