W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Charles McCathieNevile <chaals@opera.com>
Date: Tue, 19 Dec 2006 17:51:37 +0100
To: "Web API public" <public-webapi@w3.org>
Cc: "Chris Wilson" <Chris.Wilson@microsoft.com>, "Dave Massy" <dave.massy@microsoft.com>, "Anne van Kesteren" <annevk@opera.com>
Message-ID: <op.tktfsbdmwxe0ny@widsith.local>

OK folks,

Let's get this in perspective. We are trying to publish this document as a  
last call, and get on with the dozen other documents we are meant to get  
done in the next year. So I have two questions I would like answers on:

1. Does anyone see any other issue in the current draft that should be  
fixed?
2. For the following options, do you consider the names "fine", "not great  
but acceptable", or "unacceptable"?
      getElementBySelector/getElementsBySelector
      match/matchAll
      matchSelector/matchAllSelectors

    If and Only If you consider all 3 names are so bad as to be  
unacceptable, please propose an alternative.

While getting naming perfect is a great thing, I don't know of it ever  
being done before. "Shipping is a feature", as a friend who was a product  
manager at a Redmond-based software company used to remind me, and if we  
can't get nomenclative perfection then I suggest we at least enhance the  
"shipping" side of our feature list...

cheers

Chaals (wearing a slightly ill-fitting chair's hat)

-- 
   Charles McCathieNevile, Opera Software: Standards Group
   hablo español  -  je parle français  -  jeg lærer norsk
chaals@opera.com          Try Opera 9 now! http://opera.com
Received on Tuesday, 19 December 2006 16:51:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT