W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

RE: Selectors API naming

From: Ian Hickson <ian@hixie.ch>
Date: Mon, 18 Dec 2006 22:17:23 +0000 (UTC)
To: Dave Massy <Dave.Massy@microsoft.com>
Cc: Anne van Kesteren <annevk@opera.com>, "Web API WG (public)" <public-webapi@w3.org>, Chris Wilson <chris.wilson@microsoft.com>
Message-ID: <Pine.LNX.4.62.0612182217080.10136@dhalsim.dreamhost.com>
On Mon, 18 Dec 2006, Dave Massy wrote:
> 
> We'd really like to see naming to be meaningful for this and all APIs. 
> The goal should be to have a DOM that holds together as one, and 
> therefore the names matter – they need to seem like one 
> intelligently-designed API. Generic names such as select() and match() 
> don't help anyone unless they are for performing generic operations. To 
> suggest that names don't matter and "aaaaa" is fine is just wrong in our 
> opinion. We need to have an API set that people can read and understand 
> without having to go to reference material all the time to ask 
> themselves "Hmm. Now what does select() do in this particular 
> situation?".

Then we should switch to Chinese for method names.

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Monday, 18 December 2006 22:17:59 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:18:56 GMT