W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

RE: Selectors API naming

From: Chris Wilson <Chris.Wilson@microsoft.com>
Date: Mon, 18 Dec 2006 14:28:06 -0800
Message-ID: <44FAFFCDE516434D84E6B62121DB6A4404078976@WIN-MSG-21.wingroup.windeploy.ntdev.microsoft.com>
To: Ian Hickson <ian@hixie.ch>, Dave Massy <dave.massy@microsoft.com>
CC: Anne van Kesteren <annevk@opera.com>, "Web API WG (public)" <public-webapi@w3.org>
If you'd like to suggest that, I can understand the statistical reason.  Given that reserved words in the programming languages I've known all tend to be English, and all the other web standards webdevs use (including DOM, most specifically) are in English, I'd stick with it.

Look, two choices - you should either try to make a system that hangs together with the other specifications and is therefore somewhat intuitive, or you should use the short possible names and presume the user is going to look up the name every time.  I think the latter is goofy.  The former is a lesson learned, in my opinion, and applied to the .Net framework - though there are tons and tons of people involved in building .Net, by and large the APIs follow conventions in naming, and that makes the APIs feel like they were designed together.  I'd rather a webdev not have to understand "oh, this API was done by the DOM WG, so it uses this naming... this one was done by the WebAPI WG, so it uses this other one..."

-----Original Message-----
From: Ian Hickson [mailto:ian@hixie.ch] 
Sent: Monday, December 18, 2006 2:17 PM
To: Dave Massy
Cc: Anne van Kesteren; Web API WG (public); Chris Wilson
Subject: RE: Selectors API naming

On Mon, 18 Dec 2006, Dave Massy wrote:
> We'd really like to see naming to be meaningful for this and all APIs. 
> The goal should be to have a DOM that holds together as one, and 
> therefore the names matter – they need to seem like one 
> intelligently-designed API. Generic names such as select() and match() 
> don't help anyone unless they are for performing generic operations. To 
> suggest that names don't matter and "aaaaa" is fine is just wrong in our 
> opinion. We need to have an API set that people can read and understand 
> without having to go to reference material all the time to ask 
> themselves "Hmm. Now what does select() do in this particular 
> situation?".

Then we should switch to Chinese for method names.

Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Tuesday, 19 December 2006 14:31:44 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC