W3C home > Mailing lists > Public > public-webapi@w3.org > December 2006

Re: Selectors API naming

From: Maciej Stachowiak <mjs@apple.com>
Date: Thu, 14 Dec 2006 22:28:16 -0800
Message-Id: <93CC2299-B642-48C7-89A1-7B56DEB11606@apple.com>
Cc: Anne van Kesteren <annevk@opera.com>, Charles McCathieNevile <chaals@opera.com>, public-webapi@w3.org
To: Dave Massy <Dave.Massy@microsoft.com>

On Dec 13, 2006, at 9:05 AM, Dave Massy wrote:

> Moving to public-webapi@w3.org
> I don't think we are tied to a particular name for this, I think  
> getElementsByGroupOfSelectors might be a little excessive :)  
> However we'd just like the name to more clearly reflect the  
> functionality rather than a generic sounding matchAll() which isn't  
> really intended for generic use. It's our belief that it is  
> important for names to reflect what they do where possible. Having  
> a short name might save us all a few keystrokes but it is less  
> clear to developers what the call is doing and can create bigger  
> problems.

I think a short but clear name would be select(). Unfortunately that  
is taken by Microsoft's nonstandard XPath API. match() seems like a  
decent next-best choice. The idea is to make this a common idiom with  
a convenient name so people don't have to go to crazy lengths like  
making $() or $$() functions to avoid using it.

Received on Friday, 15 December 2006 06:28:45 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:16:22 UTC