W3C home > Mailing lists > Public > public-uwa@w3.org > February 2010

ACTION-16 for SystemInfo API

From: SULLIVAN, BRYAN L (ATTCINW) <BS3131@att.com>
Date: Tue, 23 Feb 2010 01:12:24 -0800
Message-ID: <8080D5B5C113E940BA8A461A91BFFFCD10D72508@BD01MSXMB015.US.Cingular.Net>
To: <public-device-apis@w3.org>, <public-uwa@w3.org>
Hi all,

Here are some further comments on the SystemInfo API. I have finished
reviewing the document and comparing it with the DCO and other standard
vocabularies. I am making a second pass to begin the process of
alignment, extension, and in general commenting on the current draft's
properties. I am preparing a detailed proposal as I mentioned, to be
ready by the Prague F2F. In the meantime I will be making specific
proposals on the items in the current draft, as I get time. 

This however is not a quick process, and DAP should not rush it. It will
take some time to create a normative set of properties that we want to
include in this first version. We will need to spend adequate time
discussing each one, to be sure we are aligned with the existing
standards work in W3C and elsewhere (e.g. OMA), and are including all
properties for which it is clear that a broad consensus considers them
important in this first SystemInfo API version. We can really only
determine that effectively by creating, as a group, what we consider a
complete set of high-priority first-release properties, and then putting
that out for public review and input on additional properties of
importance. We need to ensure that the UWA group is aware of the
discussions and has a chance to provide input as well.

Here are comments to the Power and Network properties.

Power.level should be aligned with the DCO (hard:batteryLevel (0 to 100
inclusive)).

Power.isExternal is redundant with Power.isCharging. batteryBeingCharged
(DCO hard:batteryBeingCharged) is a clearer name.

Power.timeRemaining is useful but should be described "Represents the
estimated time remaining in seconds before the battery will be depleted,
based upon current power usage. If batteryBeingCharged is true, this
value must represent the estimated time remaining in seconds before the
battery would be depleted, based upon current power usage, if external
power were removed." It should also be added to the DCO
(hard:batteryTimeRemaining).

Network: add TYPE_LTE

Overall, for network info the model provided by the DCO is more complete
and contains additional useful info on networks that are active,
available, supported, default, and preferred. 
    net:availableNetworkBearers
    dcn:currentNetworkBearer (note: in the DCO this should be
dcn:currentNetworkBearers as there may be multiple active networks)
    net:defaultNetworkBearer
    net:preferredNetworkBearer
    net:supportedNetworkBearers

operatorName is a useful convenience property and should be added to the
DCO (dcn:operatorName).

roaming should have three values: national, and international. If not
roaming, the value should be null. This should also be added to the DCO
(dcn:roaming).

Thanks, 
Bryan Sullivan | AT&T
Received on Tuesday, 23 February 2010 09:13:09 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 23 February 2010 09:13:10 GMT