W3C home > Mailing lists > Public > public-uwa@w3.org > February 2010

Re: ACTION-16 for SystemInfo API

From: Max Froumentin <maxfro@opera.com>
Date: Tue, 23 Feb 2010 14:25:40 +0100
Message-ID: <4B83D754.7050307@opera.com>
To: "SULLIVAN, BRYAN L (ATTCINW)" <BS3131@att.com>
CC: public-device-apis@w3.org, public-uwa@w3.org
Hi Bryan,

Thanks for your review. I'm looking forward to your analysis.
For now I'll just comment on the remarks below.

On 23/02/2010 10:12, SULLIVAN, BRYAN L (ATTCINW) wrote:

>
> Here are comments to the Power and Network properties.
>
> Power.level should be aligned with the DCO (hard:batteryLevel (0 to 100
> inclusive)).

Done. I've added an appendix to the draft with DCO mappings, which I'll 
complete as we go along.

> Power.isExternal is redundant with Power.isCharging. batteryBeingCharged
> (DCO hard:batteryBeingCharged) is a clearer name.

OK, I thought that isCharging was independent from isExternal, but I 
guess you can infer isExternal from batteryBeingCharged if you keep 
batteryBeingCharged to true even if the battery is fully charged.

> Power.timeRemaining is useful but should be described "Represents the
> estimated time remaining in seconds before the battery will be depleted,
> based upon current power usage. If batteryBeingCharged is true, this
> value must represent the estimated time remaining in seconds before the
> battery would be depleted, based upon current power usage, if external
> power were removed." It should also be added to the DCO
> (hard:batteryTimeRemaining).

ok. I've added an appendix with the mapping to the DCO.

> Network: add TYPE_LTE

Could you provide a short description, or ideally a reference?

> Overall, for network info the model provided by the DCO is more complete
> and contains additional useful info on networks that are active,
> available, supported, default, and preferred.

Yes, but do we need those? I had them at the beginning, but following 
our decision to simplify, I edited the spec down to only have active. 
Should we reconsider for this case?

> roaming should have three values: national, and international. If not
> roaming, the value should be null. This should also be added to the DCO
> (dcn:roaming).

national roaming: is that in some countries you could be roaming in the 
same country? Then is it important to differentiate between national and 
international roaming?

in order to properly have national and international, we should have 
constants in the interface (ROAMING_NATIONAL and ROAMING_INTERNATIONAL, 
say). Since there are already constants for connection type, there's a 
risk of collision. So we can either have:

DOMString? roaming; // "National", "International"

or

const unsigned short ROAMING_NATIONAL = 5000; //or some other bignum
const unsigned short ROAMING_INTERNATIONAL = 5001;
attribute RoamingType roaming;

or through a new interface for roaming:

...
attribute RoamingType roaming;
...

interface RoamingType {
   const unsigned short ROAMING_NATIONAL = 0;
   const unsigned short ROAMING_INTERNATIONAL = 1;
   attribute unsigned short type;
}


I like neither, but the third is the least bad, imo. What do you think?

Max.
Received on Tuesday, 23 February 2010 13:26:21 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 23 February 2010 13:26:22 GMT