W3C home > Mailing lists > Public > public-rdfa-wg@w3.org > May 2011

Re: RDF Interfaces - new draft

From: Nathan <nathan@webr3.org>
Date: Tue, 03 May 2011 10:24:47 +0100
Message-ID: <4DBFC9DF.8090106@webr3.org>
To: RDFa Working Group <public-rdfa-wg@w3.org>
CC: Ivan Herman <ivan@w3.org>, Manu Sporny <msporny@digitalbazaar.com>
Nathan wrote:
> Hi all,
> 
> Just a quick note to say that I think I'm done with the RDF Interfaces 
> specification for now, and it's ready for a sanity check before 
> preparing for FPWD.
> 
>   http://www.w3.org/2010/02/rdfa/sources/rdf-interfaces/

I've just updated the draft again with a few changes from over the 
weekend, nothing too major, some minor cleanup and:
  - removed Graph.apply, it was duplicate (and hard to optimize) 
functionality, removeMatches offers the same (and more) functionality in 
a more optimized and usable manner
  - added a 'graph' argument to TripleAction and TripleCallback
  - added a ProcessorCallback additional interface (now needed as 
previously it used TripleCallback), this is actually re-putting in an 
interface from an earlier draft
  - added a missing 'equals' method on the Triple interface (had meant 
to do that for months, somehow escaped my list)

still to do:
  - rename Triple.value to something different, Ivan has suggested 
'name', I'm half fond of 'term' but that's re-use, and I realised that I 
picked the method name 'valueOf' to align with Javascript and Java - so 
just need to rename Triple.value to save confusion and address Ivan's 
comment.

Best,

Nathan

> Since the last version there are a number of changes, I've fully 
> rewritten the definition of Literal to reflect current conversations, 
> GraphLiteral/TripleSet is gone, a couple of changes to the Graph 
> interface ('the' is gone, 'match' is added, 'removeMatches' is added), 
> RDFNode equality is redefined and clarified, a 'toValue' method is added 
> to RDFNode (particularly for working with Literals), lot's of 
> clarifications and cleanups to the text, issues and notes added etc.
> 
> Please do have a read and let me know.
> 
> Best,
> 
> Nathan
> 
> 
> 
Received on Tuesday, 3 May 2011 09:25:40 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:19:51 UTC