W3C home > Mailing lists > Public > public-prov-wg@w3.org > May 2012

Re: prov:value versus KeyValuePair

From: Timothy Lebo <lebot@rpi.edu>
Date: Tue, 15 May 2012 11:33:30 -0400
Cc: Luc Moreau <L.Moreau@ecs.soton.ac.uk>, public-prov-wg@w3.org
Message-Id: <F5A6055D-E543-491E-A8ED-75CEEB8952B3@rpi.edu>
To: Stephan Zednik <zednis@rpi.edu>
Stephan and WG,

Given Luc's response about Dictionaries providing structure to Entities, can we go with pairKey and pairValue?

Any more concerns?

Thanks,
Tim



>> Leaning towards Luc and Stephan, what about 
>> 
>> [ 
>> a prov:KeyValuePair;
>> prov:pairKey      "goalie"; 
>> prov:pairValue  :joe_the_tank;
>> ]
>> 
>> I think the property should be named by the role, not its range - otherwise we'd have pairString which is odd.
> 
> I think this goes back to my preference for prov:KeyEntityPair over prov:KeyValuePair.
> 
> Why can only entities be the value in a KeyValuePair?
> 
> --Stephan
Received on Tuesday, 15 May 2012 15:35:06 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 15 May 2012 15:35:06 GMT