W3C home > Mailing lists > Public > public-prov-wg@w3.org > July 2011

Re: PROV-ISSUE-30 (name-for-bob): What name do we use for the BOB construct? [Conceptual Model]

From: Khalid Belhajjame <Khalid.Belhajjame@cs.man.ac.uk>
Date: Sun, 24 Jul 2011 11:45:45 +0100
Message-ID: <4E2BF7D9.8010703@cs.man.ac.uk>
To: Stephan Zednik <zednis@rpi.edu>
CC: public-prov-wg@w3.org

Hi Stephan,

Given the example you gave in your previous email, I think that 
"EntitySpanshot" or "Snapshot" should be fine, given that it reflect the 
fact that it is a description of an entity that holds for some period of 
time.

Do you agree?

khalid

On 23/07/2011 20:24, Stephan Zednik wrote:
> I do not feel that EntityInstance, EntityInstantiation, or 
> InstantiatedEntity make sense for the book ownership scenario, or any 
> scenario modeling the provenance of changes in characteristics of a 
> physical object.
>
> To reiterate the example since I haven't committed it to a wiki page 
> yet.  Book X is an entity that represents a real world object.  It can 
> be put on a shelf, loaned to friends, damaged, and/or destroyed.  It 
> has important characteristics (condition, ownership, location, etc) 
> that may change over the life of the book.  We may want to represent 
> the provenance of the book as a chain of ownership.
>
> |<----------------------------------------------------- Book X 
> ----------------------------------------------------------------->|
> |<!------ Book X with owner A ---->|<----Book X with owner B 
> ---->|<---- Book X with owner A --------->|
>
> If a book changes ownership, is the "book with changed ownership" a 
> different EntityInstance?  A different InstantiatedEntity?  I don't 
> think what we current call a BOB is an 'instance of' anything.  I 
> think of it as a description of an entity that holds for some time 
> period (not necessarily given) for which contextually important 
> mutable characteristics of the the entity are held to be known.
>
> --Stephan
>
> On 7/22/2011 5:29 AM, Curt Tilmes wrote:
>> On 07/22/2011 03:43 AM, Khalid Belhajjame wrote:
>>> The term "Snapshot" was suggested some time ago, and it seems that
>>> several people did like it.
>>> We can also use the term "EntitySnapshot".
>>
>> Following from snapshot:
>>
>> EntityInstance
>> EntityInstantiation
>> InstantiatedEntity
>>
>> Curt
>>
>>
>>
>
>
>
Received on Sunday, 24 July 2011 10:46:16 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 26 April 2012 13:06:37 GMT