W3C home > Mailing lists > Public > public-multilingualweb-lt@w3.org > February 2013

Re: test suite errors

From: Felix Sasaki <fsasaki@w3.org>
Date: Thu, 28 Feb 2013 19:43:28 +0100
Message-ID: <512FA550.8030406@w3.org>
To: Multilingual Web LT-TESTS Public <public-multilingualweb-lt-tests@w3.org>, "public-multilingualweb-lt@w3.org" <public-multilingualweb-lt@w3.org>
Hi Leroy, all,

to make things easier I'll put names to the files - if you see your name 
please do the correction in the input files and the expected output 
files, and your output files. Leroy, I have put you up for provenance 
only since this is TCD, and the second full implementer Yves is handling 
other things - can you take care of provenance?

NOTE TO ALL: this will mean that you need to re-generate your output 
files too, otherwise the test suite comparison "expected - actual 
output" will break for your files.

Thanks,

Felix

Am 28.02.13 11:29, schrieb Leroy Finn:
> Felix, Everyone,
>
> I can do the corrections but not till after the *13th of March* as I 
> am currently programming an implementation for the Rome showcase. So 
> help from data categories owners would be really helpful otherwise 
> these corrections will not be able to take place till after the *13th 
> of March*. Hope everyone understands.
>
> XML INPUT:
>

LQISSUE: Yves

> validate-xml:
>      [jing] 
> its2.0/inputdata/locqualityissue/xml/locqualityissue4xml.xml:18:38: 
> error: Bad value ?1234? for attribute ?id? from namespace 
> ?http://www.w3.org/XML/1998/namespace? on element ?locQualityIssues? 
> from namespace ?http://www.w3.org/2005/11/its?.

PROV: Leroy

>      [jing] 
> its2.0/inputdata/provenance/html/provenance6htmlstandoff.xml:3:94: 
> error: Attribute ?version? not allowed on element ?provenanceRecords? 
> from namespace ?http://www.w3.org/2005/11/its? in this context.

STORAGE SIZE: Philip

>      [jing] its2.0/inputdata/storagesize/xml/storagesize9xml.xml:2:97: 
> error: Attribute ?num? not allowed on element ?span? from namespace 
> ?http://www.w3.org/2005/11/its? in this context.
>      [jing] its2.0/inputdata/storagesize/xml/storagesize9xml.xml:2:97: 
> error: Attribute ?lineBreakType? not allowed on element ?span? from 
> namespace ?http://www.w3.org/2005/11/its? in this context.
>      [jing] its2.0/inputdata/storagesize/xml/storagesize9xml.xml:3:93: 
> error: Attribute ?num? not allowed on element ?span? from namespace 
> ?http://www.w3.org/2005/11/its? in this context.
>      [jing] its2.0/inputdata/storagesize/xml/storagesize9xml.xml:3:93: 
> error: Attribute ?lineBreakType? not allowed on element ?span? from 
> namespace ?http://www.w3.org/2005/11/its? in this context.
>      [jing] its2.0/inputdata/storagesize/xml/storagesize9xml.xml:4:96: 
> error: Attribute ?num? not allowed on element ?span? from namespace 
> ?http://www.w3.org/2005/11/its? in this context.
>      [jing] its2.0/inputdata/storagesize/xml/storagesize9xml.xml:4:96: 
> error: Attribute ?lineBreakType? not allowed on element ?span? from 
> namespace ?http://www.w3.org/2005/11/its? in this context.
>
> HTML INPUT (minus disambiguation)

DOMAIN: Ankit

>  [apply] error: Element ?head? from namespace 
> ?http://www.w3.org/1999/xhtml? is missing required child element ?title?.
>     [apply] its2.0/inputdata/domain/html/domain4html.html:6:48: error: 
> Bad value ?x-mykeywords? for attribute ?name? on element ?meta? from 
> namespace ?http://www.w3.org/1999/xhtml?: Bad metadata name: Keyword 
> ?x-mykeywords? is not registered.
>     [apply] error: Element ?head? from namespace 
> ?http://www.w3.org/1999/xhtml? is missing required child element ?title?.
>     [apply] error: Element ?head? from namespace 
> ?http://www.w3.org/1999/xhtml? is missing required child element ?title?.

ELEMENTS WITHIN TEXT: Marcis

>     [apply] 
> its2.0/inputdata/elementswithintext/html/withintext1html.html:9:11: 
> error: Element ?title? from namespace ?http://www.w3.org/1999/xhtml? 
> not allowed in this context. (The parent was element ?section? from 
> namespace ?http://www.w3.org/1999/xhtml?.) Suppressing further errors 
> from this subtree.
>     [apply] error: Element ?head? from namespace 
> ?http://www.w3.org/1999/xhtml? is missing required child element ?title?.
>     [apply] 
> its2.0/inputdata/elementswithintext/html/withintext3html.html:9:11: 
> error: Element ?title? from namespace ?http://www.w3.org/1999/xhtml? 
> not allowed in this context. (The parent was element ?section? from 
> namespace ?http://www.w3.org/1999/xhtml?.) Suppressing further errors 
> from this subtree.
>     [apply] error: Element ?head? from namespace 
> ?http://www.w3.org/1999/xhtml? is missing required child element ?title?.
>     [apply] 
> its2.0/inputdata/elementswithintext/html/withintext4html.html:17:11: 
> error: Element ?title? from namespace ?http://www.w3.org/1999/xhtml? 
> not allowed in this context. (The parent was element ?section? from 
> namespace ?http://www.w3.org/1999/xhtml?.) Suppressing further errors 
> from this subtree.

EXTERNAL RESOURCE: Shaun

>     [apply] 
> its2.0/inputdata/externalresource/html/externalresource2html.html:15:6: error: 
> Element ?p? from namespace ?http://www.w3.org/1999/xhtml? not allowed 
> in this context. (The parent was element ?video? from namespace 
> ?http://www.w3.org/1999/xhtml?.) Suppressing further errors from this 
> subtree.

LQI: this is not an update needed - as Jirka pointed out in a separate 
mail, the schema very likely needs an update since data-* attributes are 
allowed in HTML.


>     [apply] 
> its2.0/inputdata/locqualityissue/html/locqualityissue4html.html:22:9: 
> error: Attribute ?data-mytool-qacode? not allowed on element ?span? 
> from namespace ?http://www.w3.org/1999/xhtml? in this context.
>     [apply] 
> its2.0/inputdata/locqualityissue/html/locqualityissue5html.html:22:65: 
> error: Attribute ?data-mytool-qacode? not allowed on element ?span? 
> from namespace ?http://www.w3.org/1999/xhtml? in this context.
>     [apply] 
> its2.0/inputdata/locqualityissue/html/locqualityissue6html.html:25:37: 
> error: Attribute ?data-mytool-qacode? not allowed on element ?span? 
> from namespace ?http://www.w3.org/1999/xhtml? in this context.
>
>
> Thanks,
> Leroy
>
Please do the changes by Monday next week and tell the test list then 
its done, so that implementers can re-genrate their output.


Thanks to all for you help,

Felix
Received on Thursday, 28 February 2013 18:43:53 UTC

This archive was generated by hypermail 2.3.1 : Sunday, 9 June 2013 00:25:08 UTC