W3C home > Mailing lists > Public > public-i18n-its@w3.org > January to March 2006

[Bug 3017] rename documentRules and documentRule

From: <bugzilla@wiggum.w3.org>
Date: Wed, 22 Mar 2006 16:54:03 +0000
CC:
To: public-i18n-its@w3.org
Message-Id: <E1FM6ax-0001qC-NM@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=3017





------- Comment #4 from ysavourel@translate.com  2006-03-22 16:54 -------
This issue (Bug #3017) is one of the topics for discussion this week (and
decision at the Wed Mar-29 teleconference).

Summary:

1) The question: how should the current 'documentRules' should be named?

Since we don't have schemaRules the name documentRules may not be appropriate
anymore. [Note that the renaming of documentRule is resolved since we decided
to go for translateRule, termRule, etc.]

Several names are proposed: globalRules, itsRules, rules.


2) The question: what should be the suffix for the 'value passing/pointing'
attribute?

The name of the attributes that use to be called xyzMap in the Mandelieu
proposal need to reflect their 'value passing/pointing' aspect rather than a
'mapping' that is something different. This applies for: locInfoMap,
locInfoRefMap, rubyBaseMap, rubyTextMap, termRefMap, etc.

Several suffixes are proposed: xyzPointer, xyzPassThrough, xyzValue (and I may
forget some).


My personnal (current) option:

1) rules
2) xyzPointer

-yves
Received on Wednesday, 22 March 2006 16:55:11 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:43:06 UTC