W3C home > Mailing lists > Public > public-hydra@w3.org > July 2014

Re: Call for consensus on renaming "statusCodes" to "possibleStatus" and "StatusCodeDescription" to "Status" (ISSUE-27)

From: Tomasz Pluskiewicz <tomasz@t-code.pl>
Date: Wed, 16 Jul 2014 20:19:08 +0200
Message-ID: <CAAFOhSdF=MX1KudKPLUK1gH5j=wSDFKNiSnhB=eKmngXfru2wQ@mail.gmail.com>
To: Gregg Kellogg <gregg@greggkellogg.net>
Cc: Markus Lanthaler <markus.lanthaler@gmx.net>, "public-hydra@w3.org" <public-hydra@w3.org>
+1
I think that Ruben's suggestion makes sense. I'm just a little
uncertain about "possibleStatus" property. Wouldn't simply status
suffice?

On Wed, Jul 16, 2014 at 7:31 PM, Gregg Kellogg <gregg@greggkellogg.net> wrote:
>
> Gregg Kellogg
> gregg@greggkellogg.net
>
> On Jul 16, 2014, at 10:09 AM, Markus Lanthaler <markus.lanthaler@gmx.net> wrote:
>
>> Currently, we have an hydra:statusCodes property on ApiDocumentation and
>> Operation that points to a StatusCodeDescription. That StatusCodeDescription
>> then in turn has a hydra:statusCode property which expresses the HTTP status
>> code. This is very confusing. Thus, the proposal is to rename "statusCodes"
>> to "possibleStatus" and "StatusCodeDescription" to "Status". We will then
>> describe in the spec that these are enumerations of possible statuses that
>> might be returned at runtime and to tell the developer (in prose in
>> hydra:description) how to recover from errors etc.
>
> +0
>
>> This serves as a call for consensus. Before I proceed with marking the issue
>> [1] as resolved and implementing the changes in the spec, I would like to
>> ask if anyone has any concerns or objections against this proposal.
>>
>> Please submit your comments by Wednesday, July 23rd.
>>
>>
>> Thanks,
>> Markus
>>
>> [1] https://github.com/HydraCG/Specifications/issues/27
>>
>>
>> --
>> Markus Lanthaler
>> @markuslanthaler
>>
>>
>>
>>
>
>
>
Received on Wednesday, 16 July 2014 18:20:44 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:29:42 UTC