W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2012

[Bug 19561] WaveTable is poorly named

From: <bugzilla@jessica.w3.org>
Date: Wed, 17 Oct 2012 08:16:13 +0000
To: public-audio@w3.org
Message-ID: <bug-19561-5429-eJSWNgKnfr@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=19561

Marcus Geelnard (Opera) <mage@opera.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mage@opera.com

--- Comment #3 from Marcus Geelnard (Opera) <mage@opera.com> ---
I think I'm with Chris Wilson here. I find it a bit counterintuitive to have
"Wave" in the name at all, since to me, a wave is a time domain thing but the
WaveTable object holds frequency domain data (it's the OscillatorNode that
produces the wave, not the WaveTable object).

More precisely, the data held in the object is the Fourier series of a periodic
wave, but I guess PeriodicWaveFourierSeries is a bit too wordy to be practical?

As usual, interface naming is about the hardest thing you can do in computer
science ;)

Here's another thought: You could treat the WaveTable object in a way that is
independent of frequency/time domain. For instance, if the interface provided a
way to set the object state from a time domain signal as well as from a
frequency domain signal, and let it be up to the implementation to choose how
to store the data internally (could be frequency domain for hi quality
synthesis or time domain for low quality synthesis), and use FFT/IFFT
internally for the setters, as appropriate for the implementation.

If so, I think "PeriodicWave" would be a very fitting name.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
Received on Wednesday, 17 October 2012 08:16:13 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:50:03 UTC