[Bug 18332] Node creation method naming inconsistencies

https://www.w3.org/Bugs/Public/show_bug.cgi?id=18332

--- Comment #4 from Marcus Geelnard (Opera) <mage@opera.com> ---
(In reply to comment #3)
> Now that 17407 is resolved, how do the two method name-changes sound?

Given your suggestion, we'd get:

createBufferSource -> AudioBufferSourceNode
createMediaElementSource -> MediaElementAudioSourceNode
createMediaStreamSource -> MediaStreamAudioSourceNode
createScriptProcessor -> ScriptProcessorNode
createAnalyser -> AnalyserNode
createGain -> GainNode
createDelay -> DelayNode
createBiquadFilter -> BiquadFilterNode
createWaveShaper -> WaveShaperNode
createPanner -> PannerNode
createConvolver -> ConvolverNode
createChannelSplitter -> ChannelSplitterNode
createChannelMerger -> ChannelMergerNode
createDynamicsCompressor -> DynamicsCompressorNode
createOscillator -> OscillatorNode

This looks very intuitive to me. The only thing sticking out here are the three
first nodes, where "Audio" is somehow in the node name (which seems right IMO),
but not in the create* method name.

I don't have any objections to that (shorter names = good thing™), other than
the possible loss of distinction between Audio/Video Media sources that you
mentioned in Bug 17407. Any thoughts?

-- 
You are receiving this mail because:
You are the QA Contact for the bug.

Received on Wednesday, 17 October 2012 07:13:39 UTC