W3C home > Mailing lists > Public > ietf-dav-versioning@w3.org > April to June 2001

RE: Versioning Packages

From: Clemm, Geoff <gclemm@rational.com>
Date: Wed, 18 Apr 2001 09:52:23 -0400
Message-ID: <3906C56A7BD1F54593344C05BD1374B102B90047@SUS-MA1IT01>
To: ietf-dav-versioning@w3.org
I agree with Tim's point about the negative result of having
a feature called "checkout" when the CHECKOUT method actually
appears in two features (the "checkout" feature and the
"working resource" feature").  A more "accurate" name for the
"checkout" feature would be "in-place-version-controlled-resource-checkout".
I'm really not very fond of this extended name (:-) ... anyone
have a better solution?

One alternative that comes to mind is to fold the "checkout"
option into the "workspace" option, but as I recall, there are
folks that wanted to support the "in-place checkout" but did not
want to support workspaces.  Just to check, is there anyone out
there that will be supporting "in-place checkout" but not workspaces?

Alternatively, if anyone can come up with a better name for the
"in-place-version-controlled-resource-checkout" feature,
that would be appreciated!


-----Original Message-----
From: Tim_Ellison@uk.ibm.com [mailto:Tim_Ellison@uk.ibm.com]
Sent: Wednesday, April 18, 2001 6:59 AM
To: ietf-dav-versioning@w3.org
Subject: Re: Versioning Packages

"Clemm, Geoff" <gclemm@rational.com> wrote:

> I did another pass through the "packages"
> description. In particular, I gave the common
> intersection of all packages (which is just the
> "version-control" feature) its own package name
> (the "core-versioning" package).
> There is more information on the "server workspace"
> and "client workspace" differences in the "workspace
> feature" and "working resource feature" descriptions.
> Does this look OK?

Yes.  It would be preferrable if the features had names that did not
collide with method names since that triped me up, and I can imagine it
being a source of confusion in the future -- e.g. "when you say your server
implements checkout, do you mean the 'checkout' feature or the 'CHECKOUT'
method?", the feature being a subset of the method.

wrt packages of features, I'm quite indifferent to the idea.

Received on Wednesday, 18 April 2001 09:50:47 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:55:47 UTC