W3C home > Mailing lists > Public > ietf-dav-versioning@w3.org > April to June 2001

RE: Versioning Packages

From: <Tim_Ellison@uk.ibm.com>
Date: Wed, 18 Apr 2001 15:45:21 +0100
To: ietf-dav-versioning@w3.org
Message-ID: <80256A32.005111D7.00@d06mta07.portsmouth.uk.ibm.com>

"Clemm, Geoff" <gclemm@rational.com> wrote:

> I agree with Tim's point about the negative result
> of having a feature called "checkout" when the CHECKOUT
> method actually appears in two features (the "checkout"
> feature and the "working resource" feature").  A more
> "accurate" name for the "checkout" feature would be
> "in-place-version-controlled-resource-checkout". I'm
> really not very fond of this extended name (:-) ...
> anyone have a better solution?
> One alternative that comes to mind is to fold the
> "checkout" option into the "workspace" option, but as
> I recall, there are folks that wanted to support the
> "in-place checkout" but did not want to support workspaces.
> Just to check, is there anyone out there that will be
> supporting "in-place checkout" but not workspaces?

I would like to see these options kept separate.

> Alternatively, if anyone can come up with a better name
> for the "in-place-version-controlled-resource-checkout"
> feature, that would be appreciated!

The 'in-place-' is superfluous.  Given that the feature is to check out a
vcr, it isn't going to get much shorter than

Received on Wednesday, 18 April 2001 10:46:23 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:55:47 UTC