W3C home > Mailing lists > Public > xproc-dev@w3.org > October 2020

Re: Morgana and Schematron configuration question

From: Achim Berndzen <achim.berndzen@xml-project.com>
Date: Sat, 3 Oct 2020 11:54:39 +0200
Cc: xproc-dev@w3.org
Message-Id: <31732B9C-0B6E-40DB-97FE-08BF25022094@xml-project.com>
To: David Birnbaum <djbpitt@gmail.com>
Hi David,
I think that Martin is right: The problem raises from the fact, that "-config" is expected to be the first element on the command line. In any other position it is ignored, so MorganaXProc is not configured the way you expect it.

In the next version of MorganaXProc, I changed the command line behavior: Now either -config is the first element on the command line or an error is raised to tell you about the problem.

Greetings from Germany,
Achim Berndzen

<xml-project /> Achim Berndzen
Kleine Breite 26a
38302 Wolfenbüttel, Germany


> Am 02.10.2020 um 21:22 schrieb David Birnbaum <djbpitt@gmail.com>:
> Daer xproc-dev,
> I'm stumbling over configuring Schematron validation in MorganaXProc-IIIse and I would be grateful if someone could help me track down where I've done astray. All of the Morgana functionality seems to be working except Schematron. I've done the following:
> 	• Installed Morgana at /opt/morgana/MorganaXProc-IIIse- It runs as expected.
> 	• Copied saxon-ee-10.0.jar into /opt/morgana/MorganaXProc-IIIse- Morgana finds and uses Saxon when I run zsh /opt/morgana/MorganaXProc-IIIse- $1 -xslt-connector=Saxon10 -xquery-connector=Saxon10 on the command line.
> 	• To try to use Schematron I then:
> 		• Copied schxslt-1.5.1.jar into that same Morgana lib subdirectory.
> 		• Downloaded SchXSLT to /opt/schxslt/schxslt-1.5.1/.  That directory contains a subdirectory called 2.0, which contains the SchXSLT XSLT files.
> 		• Edited the config.xml file in my Morgana main directory to include the line <path_to_SchXSLT_2>/opt/schxslt/schxslt-1.5.1/2.0</path_to_SchXSLT_2>.
> 		• Tried running an XProc pipeline from the command line with zsh /opt/morgana/MorganaXProc-IIIse- $1 -config=/opt/morgana/MorganaXProc-IIIse- -xslt-connector=Saxon10 -xquery-connector=Saxon10.
> This fails with the following error message::
> djb@koala-4 adj % zsh /opt/morgana/MorganaXProc-IIIse- adj.xpl -config=/opt/morgana/MorganaXProc-IIIse- -xslt-connector=Saxon10 -xquery-connector=Saxon10
> =================================
> MorganaXProc-IIIse
> Copyright 2011-2020 by <xml-project /> Achim Berndzen
> =================================
> [15:04:43.551] Selecting adjectives from dictionary
> Using Saxon-EE 10.0. XSLT and XQuery processor developed by Saxonica Limited
> [15:04:46.102] Verifying that all paradigms in dictionary are in paradigms file
> Using Saxon-EE 10.0. XSLT and XQuery processor developed by Saxonica Limited
> SchXslt is copyright (c) 2018-2020 by David Maus <dmaus@dmaus.name> and released under the terms of the MIT license.
> Unable to find path for SchXSLT for XSLT 2.0.
> <?xml version="1.0" encoding="UTF-8"?>
> <c:errors xmlns:c="http://www.w3.org/ns/xproc-step"><c:error code="err:XC0151" name="!1.4" type="p:validate-with-schematron" href="file:///Users/djb/repos/cz/pos/adj/adj.xpl" line="35" column="31" xmlns:p="http://www.w3.org/ns/xproc" xmlns:err="http://www.w3.org/ns/xproc-error"><message>Error occurred: Unable to initialize schematron templates. Reason: Required files for XSLT 2.0 based Schematron not found. Please check your config. [java.lang.Exception] [java.lang.Exception]</message></c:error></c:errors>
> It looks as if there must be some configuration step that I've overlooked or implemented incorrectly, but when I read the Morgana documentation at https://www.xml-project.com/files/doc/manual.html, I can't spot the difference between the instructions there and what I've done. Might someone be able to advise? Thank you!
> Best,
> David
Received on Saturday, 3 October 2020 09:54:55 UTC

This archive was generated by hypermail 2.4.0 : Saturday, 3 October 2020 09:54:56 UTC