W3C home > Mailing lists > Public > xproc-dev@w3.org > October 2015

java exception running calabash

From: Nic Gibson <nicg@corbas.co.uk>
Date: Wed, 7 Oct 2015 06:50:03 +0100
Message-Id: <CD8C09D8-8B9D-4ECE-A891-0F86A4D5ED46@corbas.co.uk>
To: XProc Dev <xproc-dev@w3.org>
Hi all

I’ve just set up a new mac, installed java, installed saxon, calabash, etc. And I’m now getting a java exception on running calabash. I’m by no means a java expert so I thought I would ask for your wisdom. I’ve got a stock install of xmlcalabash. I’ve moved the saxon EE jars out of the way so that they can’t be the issue. Calabash is the most recent version (1.1.9-96).

I’ve got two java versions installed:


➜  java git:(master) /usr/libexec/java_home -V
Matching Java Virtual Machines (2):
    1.8.0_45, x86_64:	"Java SE 8"	/Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home
    1.7.0_79, x86_64:	"Java SE 7"	/Library/Java/JavaVirtualMachines/jdk1.7.0_79.jdk/Contents/Home

/Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home

I’ve tried both but whichever I run I get this exception:

➜  java git:(master) java  com.xmlcalabash.drivers.Main
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.NoClassDefFoundError: net/sf/saxon/s9api/SaxonApiException
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
	at java.lang.Class.privateGetMethodRecursive(Class.java:3048)
	at java.lang.Class.getMethod0(Class.java:3018)
	at java.lang.Class.getMethod(Class.java:1784)
	at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Caused by: java.lang.ClassNotFoundException: net.sf.saxon.s9api.SaxonApiException
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 7 more


Saxon itself runs just fine. 

Can anyone suggest if this might be a java issue or a calabash issue? I’m running OS X 10.11 (El Capitan). Anyone have it running on that?

thanks


nic
Received on Wednesday, 7 October 2015 05:50:34 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 October 2015 05:50:35 UTC