W3C home > Mailing lists > Public > xproc-dev@w3.org > August 2013

Re: Using document() from Calabash with a document containing xi:includes

From: Imsieke, Gerrit, le-tex <gerrit.imsieke@le-tex.de>
Date: Sun, 25 Aug 2013 09:22:26 +0200
Message-ID: <5219B0B2.4020609@le-tex.de>
To: xproc-dev@w3.org
Hi David,

I haven’t tried it myself, but if you look at 
, it seems as if you can specify xInclude="true" there.

Of course you’ll have to point Calabash to the custom Saxon config file 
as per http://xmlcalabash.com/docs/reference/cfg.saxon-configuration.html

This seems to work only for PE or EE versions of Saxon.

And you’ll have to rely on an XInclude-capable parser being used and on 
the Saxon configuration options being passed to that parser. Don’t know 
whether Calabash overrides the parser configuration that a standalone 
Saxon would use.

These are just my utterly uninformed and amateurish $0.02.


On 25.08.2013 05:08, David Cramer wrote:
> Btw., here's the pipeline and xslt:
> https://github.com/rackerlabs/olink-maven-plugin/blob/master/src/main/resources/olink/olink.xpl
> https://github.com/rackerlabs/olink-maven-plugin/blob/master/src/main/resources/olink/make-olink-db.xsl
> The input document would look like this:
> <books xmlns="http://docs.rackspace.com/olink">
>    <book path="src/docbkx/writers-guide.xml"/>
> </books>
> The xslt uses the DocBook xslts to create the target database for each
> document and spits out a single olink target database for the
> book/@paths specified.
> Regards,
> David
> On 08/24/2013 10:02 PM, David Cramer wrote:
>> Hi there,
>> I have an xslt that uses document() to open an xml document containing
>> xi:includes. When I run the xslt directly with Saxon 9.x (including the
>> -xi:on switch), it resolves all the xi:includes are resolved as
>> expected. However when I invoke this xslt from within an Xproc pipeline
>> processed by Calabash, the xincludes are not resolved. Is there a way to
>> cause the document() function to resolve xincludes when invoked from
>> p:xslt in Calabash? I've tested this with Calabash 1.0.13-94.
>> Regards,
>> David
Received on Sunday, 25 August 2013 07:22:59 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:17:13 UTC