RE: mustUnderstand reformulation

Sounds good! - a few comments:

* I would use "Blocks tagged with a SOAP.." rather than "Elements tagged
with a SOAP..." as the attribute is context sensitive

* There might be a few places where "block" replaces the earlier "entry"

* I would replace "In general, processors SHOULD NOT..." with
"Processors SHOULD NOT..." as it always is a SHOULD NOT.

* Maybe also consider removing the last sentence as it is slightly
redundant and format the last paragraph as a note (italics?) in the spec
so that it is clear that it is a suggestion (not that I think it is a
bad one :)

* Replace 'labeled mustUnderstand="1"' with 'tagged with a
mustUnderstand attribute with the value of "1"' as it seems slightly
more consistent with the first paragraph and less syntax specific. Btw,
I like using "true" instead of "1".


Henrik Frystyk Nielsen

>Glen Daniels and I were asked to propose a reformulation for 
>"mustUnderstand".  What follows is a first cut for review and 
>discussion by the workgroup.  The reformulation also attempts 
>to remove overlap between section 4.2.3 and the processing 
>model stuff.  We did this in parallel with Mark Hadley's work 
>on eliminating overlap, so we probably unintentionally 
>duplicated some of his effort.  Presumably, the two approaches 
>can easily be reconciled if the workgroup believes that our 
>overall direction is correct.
>Also, in preparing this note, I noticed a potential issue 
>which perhaps should be added to our list for tracking: not 
>just in these sections, but in the specification overall, have 
>we made the changes necessary to allow for Boolean attributes 
>such as mustUnderstand to take the value of "true" as well as 
>"1"?  I did not make that change below.

Received on Monday, 6 August 2001 19:56:50 UTC