Suggested editorial changes to adjuncts section 4.1.1 wrpc:signature

Section 4.1.1 of the WSDL adjuncts document contains some complex 
assertions. (Assertions that have two assertion statements or are 
difficult to understand.) I'd like to propose some changes. Note that I 
don't think any of my proposed changes change the meaning of the 
specification. The changes are simply editorial/formatting changes that 
should make it easier to understand the assertions and, for 
implementations and the test suite, easier to identify when an assertion 
has been violated. I've attached a patch for wsdl20-adjuncts.xml that 
contains these changes.


1. "For each child element of the input and output messages of the 
operation, a pair (q, t) whose first component q is equal to the qualified 
name of that element MUST be present in the list, with the caveat that 
elements that appear with cardinality greater than one MUST be treated as 
a single element.? "

I'd like to suggest a simple grammatical correction to make this more 
readable.

For each child element of the input and output messages of the operation, 
a pair (q, t), whose first component q is equal to the qualified name of 
that element, MUST be present in the list, with the caveat that elements 
that appear with cardinality greater than one MUST be treated as a single 
element.?


2. "For each pair (q, #in), there MUST be a child element of the input 
element with a name of q and there MUST NOT be a child element of the 
output element with the same name.?"

For each pair (q, #in), there MUST be a child element of the input element 
with a name of q.
For each pair (q, #in), there MUST NOT be a child element of the output 
element with the name q.


3. "For each pair (q, #out), there MUST be a child element of the output 
element with a name of q and there MUST NOT be a child element of the 
input element with the same name.?"

For each pair (q, #out), there MUST be a child element of the output 
element with a name of q.
For each pair (q, #out), there MUST NOT be a child element of the input 
element with the name q.


4. "For each pair (q, #inout), there MUST be a child element of the input 
element with a name of q and there MUST be a child element of the output 
element with the same name. Furthermore, those two elements MUST have the 
same type.?"

For each pair (q, #inout), there MUST be a child element of the input 
element with a name of q and there MUST be a child element of the output 
element with the same name.

In this case I'd like to drop the "Furthermore, those two elements MUST 
have the same type." as this is redundant with assertion RPCStyle-5018. If 
it's felt that this should be kept I think the statement should be removed 
from the assertion and preferably rephrased to remove the MUST keyword 
that indicates an assertion. (I think it's potentially dangerous for the 
spec to define the same assertion twice.)


5. "For each pair (q, #return), there MUST be a child element of the 
output element with a name of q and there MUST NOT be a child element of 
the input element with the same name.? "

For each pair (q, #return), there MUST be a child element of the output 
element with a name of q.
For each pair (Q, #return), there MUST NOT be a child element of the input 
element with the name q.


Thanks,

Lawrence Mandel

Software Developer
IBM Rational Software
Phone: 905 - 413 - 3814   Fax: 905 - 413 - 4920
lmandel@ca.ibm.com

Received on Thursday, 6 July 2006 19:16:47 UTC