Re: Editorial for Part 1 section 2.18

On Aug 3, 2004, at 11:00 AM, Martin Gudgin wrote:

> I believe the property used to be called {namespace name} and was
> populated with the value of wsdl:definitions/@targetNamespace.
> Personally, I think {namespace name} is the better name, as the 
> property
> is NOT a *target* namespace when it appears on an interface component (
> or any other component for that matter ). To my mine, the notion of
> target namespace is purely a serialization detail.

FWIW, I have no stake in the naming, just the consistency. As it 
stands, there is not reference I was able to find to a {namespace name} 
anywhere except this section. That leaves QName resolution undefined, 

But while I'm here, I would find a table/index of components and 
component properties very handy (perhaps in the Primer).

(E.g., something like:

Whoa, they liked it so much that the did it twice:

If people thought it was worth having, I'd volunteer to compile such an 

Bijan Parsia.

Received on Tuesday, 3 August 2004 06:42:31 UTC