W3C home > Mailing lists > Public > www-ws-desc@w3.org > June 2003

RE: targetResource wording

From: David Orchard <dorchard@bea.com>
Date: Fri, 20 Jun 2003 15:13:01 -0700
To: "'David Booth'" <dbooth@w3.org>, "'Mark Baker'" <distobj@acm.org>
Cc: <www-ws-desc@w3.org>
Message-ID: <009f01c33779$1e654670$fefb000a@beasys.com>

I think that DavidB is missing Mark's point.  I think that Mark's point is
that the word "resource" is redundant.  The fact that the data type of
targetResource is URI, means that it asserts a resource exists.  We don't do
this with any other things with type URI.  For example, we call namespaces
either namespace names or namespace URIs - either the name or the data type.
We don't call it namespaceResource.  Even though author of the document that
is defining the space of names clearly thinks of the namespace name as a
resource that means the aggregate of all the names defined by the document.

Personally, I'm fairly ambivalent.  I can see the point about wanting to
remove the word Resource - and I argued for such in Rennes - but I can also
see that "target" by itself somehow seems to imply more than is intended.  I
can just see the confusion in the public "You have to have targets for all
your services!", etc.  I certainly didn't come up with any better names that
better indicated the ephemeral and invisible assocation between the
identified resources.  I did think that technically speaking, target URI or
target name or target Identifier (ala namespaces) are better because the
targetResource attribute is not the resource, it's actually the identifier.


> -----Original Message-----
> From: www-ws-desc-request@w3.org [mailto:www-ws-desc-request@w3.org]On
> Behalf Of David Booth
> Sent: Friday, June 20, 2003 9:50 AM
> To: Mark Baker
> Cc: www-ws-desc@w3.org
> Subject: Re: targetResource wording
> At 08:46 PM 6/19/2003 -0400, Mark Baker wrote:
> > >From Sanjiva and Mike, I understood that the
> [targetResource] attribute
> > identified a "chunk of software" (my words),
> Some of the earlier postings may have used language or
> examples that gave
> that impression, but it's incorrect.  The resource it
> identifies *could* be
> a chunk of software, but it's entirely up to the
> (application-defined)
> semantics of those particular WSDL descriptions.  WSDL 1.2
> has nothing to
> say about whether that resource is or is not a chunk of
> software.  And in
> the printer example, it probably would *not* be.
> >Where it gets really confusing for me is when words like
> "resource" and
> >"manipulation" are used, as you do there, because that suggests that
> >we're talking about the actual resource(s?) which are manipulated at
> >runtime behind the service.  So rather than "a chunk of software in
> >the printer", I get the impression that you're saying that the URI
> >identifies "the printer",
> Yes, in the printer example it would probably represent "the
> printer" --
> not a "chunk of software".
> > > Regarding the name "targetResource", u does identify a
> resource, so the
> > > "Resource" part of the name definitely is appropriate.
> >
> >I strongly disagree.  By that measure, everything which accepts a URI
> >as an argument should be called "resource".
> I think what you're saying here is that just because URI u
> exists, that
> does not magically cause a corresponding resource r to exist.
>  That is
> correct.  However, the "targetResource='u'" is *asserting*
> that such a
> resource exists.  The assertion could be false, but that's what it is
> asserting.  It is analogous to the fact that a WSDL document
> is *asserting*
> that a corresponding service exists.  It might not, but
> that's what the
> WSDL document is asserting.
> --
> David Booth
> W3C Fellow / Hewlett-Packard
> Telephone: +1.617.253.1273
Received on Friday, 20 June 2003 18:13:05 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:06:30 UTC