running on NT now ok, but had some trouble, cvs - not ok

Hello, everybody! :-)

First, about me:
1) HTML/java developer
2) post graduate student at Moscow State University,

Now what I had to overcome to run on NT:

1) i do not know why, but i failed to login to the cvs

   cvs -d login

   password 'anonymous' wouldn't let me in :-(
   it would say
   'cvs [login aborted]: authorization failed: server
   rejected access'

   so i had to use what i could download in

2) running with ActivePerl- on NT 4.0 sp6
   Apache 1.3.20 built with VC 6.0
   (had to tweak the check script in several places
   to set up dirs, had to ppm install Text::Iconv)
   very annonying trouble: at the lines

544   open CHECKER, "|$command - >$temp.esis"
545      or &internal_error ("open(|$command - >$temp.esis) returned: $!");

   i kept getting the following error:
   open(|........) returned: Bad file descriptor

   the funny thing is that when i removed


   that is output redirection it didn't fail with 'Bad file
   descriptor' any more. It worked the wrong way, but no
   'Bad file descriptor'.

   I even replaced the whole command with my own aaa.cmd
   file with no arguments and had: if

   my $command = "<path>\\aaa.cmd"
   open CHECKER, "|$command"

   it didn't fail here. If i had

   my $command = "<path>\\aaa.cmd"
   open CHECKER, "|$command > any-file-name"

   it again returned 'Bad file descriptor'

   Has anyone hit these problems except me?
   I ended with writing a .c prog that wrapped
   msngml.exe and did output redirection, then
   it worked

3) I downloaded (and even recompiled)

   I got the impression that the code
   in check was written supposing
   that nsgmls.exe would generate
   errors in it's error file of the form

   <OSFD>0:29:9:E: err-msg

   while nsgmls.exe really generates

   some-path-to\nsgmls.exe:<OSFD>0:29:9:E: err-msg

   so i had to tweak code in check again.
   Is this the code that really runs on the web?

4) sp-1.3.4 distribution for Win32 really contains

   nsgmls.exe nsgmlnorm.exe spam.exe spent.exe sx.exe

   but neither 'lq-nsgmls', nor 'onsgmls' that are used
   to initialize $sp and $osp in the text of the
   script. I can guess that 'nsgmls.exe' should be used
   instead of 'onsgmls', but what to take instead
   of 'onsgmls'?
   Does unix and NT distribution differ so much? Or is
   check out of date?

Best regards,
 Tagunov Anton

P.S. Maybe i could assist in writing a HOWTO
     on running the validator service on windows.

     As the matter of fact i have already seen
     a bit of it on the web, the text attached,
     sure it may be corrected, i may try to do
     it if you're interested.

Received on Monday, 3 December 2001 00:37:55 UTC