W3C home > Mailing lists > Public > www-validator-cvs@w3.org > May 2009

[Bug 6865] New: Version link leads to wrong history entry

From: <bugzilla@wiggum.w3.org>
Date: Wed, 06 May 2009 05:45:46 +0000
To: www-validator-cvs@w3.org
Message-ID: <bug-6865-169@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=6865

           Summary: Version link leads to wrong history entry
           Product: Validator
           Version: HEAD
          Platform: All
               URL: http://validator.w3.org/
        OS/Version: All
            Status: NEW
          Severity: trivial
          Priority: P4
         Component: Website
        AssignedTo: dave.null@w3.org
        ReportedBy: helder.magalhaes@gmail.com
         QAContact: www-validator-cvs@w3.org


Following the version link ("v0.8.5" as of this writing) leads to a previous
history entry [1] (corresponding to version 0.8.4), whereas the current version
link [2] would be expected.

Although a trivial issue, it can become a bit misleading: for example, I've
taken a few seconds before realizing that the history entry wasn't the expected
one (and, given that I knew exactly what to search for within the history
entry, that wasn't even a typical use-case).

I've searched within the bug tracker and the mailing list and didn't find
anything appropriate (but keyword-based searches can sometimes slip the desired
items so please feel free to point me out to relevant issues and/or mailing
list threads).


Reproduces:
Always.

Steps to reproduce:
1. Open the report's URL [3];
2. Follow the version link (found at the bottom of the page).

Expected results:
Retrieved link would be the hash corresponding to the latest version entry [2]
("0.8.5", dated from 2009-03-26).

Actual results:
Retrieved link corresponds to the previous version entry [1] ("0.8.4", dated
from 2008-11-20).


[1] http://validator.w3.org/whatsnew.html#t2008-11-20
[2] http://validator.w3.org/whatsnew.html#t2009-03-26
[3] http://validator.w3.org/


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Wednesday, 6 May 2009 05:45:57 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 23:02:35 UTC