- From: Thomas B. Passin <tpassin@comcast.net>
- Date: Mon, 30 Jun 2003 10:49:30 -0400
- To: <www-rdf-interest@w3.org>
[Roger L. Costello > I will take a stab at it. Let me take a complete example. Suppose that > I want to express this: The length of the Yangtze River is 6300 > kilometers. Here's how I think it would be expressed using the above > triple: > > <River rdf:ID="Yangtze"> > <length> > <LengthMeasure> > <transform> > <LengthInKilometers> > <value>6300</value> > </LengthInKilometers> > </transform> > </LengthMeasure> > </length> > </River> > > Read this as: "The value of length is a resource of type LengthMeasure. > LengthMeasure has a transform to LengthInKilometers. The > LengthInKilometers is 6300." > > Do you agree that this is a faithful XML expression of the above > triple? If not, how would you express it? /Roger Not quite. My original version had two properties for the transform - its type and its value. Your version has the actual numerical value being a property of the transform instead of being a property of the actual physical quantity. The transform exists as a mapping independently from any particular value, so the 6300 should not be one of its properties. Here is what I think is a faithful reflection of the original intent (modulo namespaces, of course) - <River rdf:ID="Yangtze"> <length-measure> <value> <transform rdfs:type='#LengthInKilometers'/> <number>6300</number> </value> </length-measure> </River> Notice how the length-measure bnode (which could be given an ID of its own to remove its "b-ness") is a resource in its own right, so you could make other statements about it. As I think about it, I think the transform bit would better be written like this instead - <transform rdf:resource='#LengthInKilometers'/> Notice in this version that the transform is referred to as actually being another resource. The idea is that each of these transforms would be an object or concept in its own right - like a singleton - it gets defined once and reused as often as necessary. I think this approach would be preferable, but either way would work OK. Clear? Comments? Cheers, Tom P
Received on Monday, 30 June 2003 10:45:58 UTC