- From: <MDaconta@aol.com>
- Date: Sun, 8 Jun 2003 12:57:42 EDT
- To: costello@mitre.org, www-rdf-interest@w3.org
- Message-ID: <34.3add26e1.2c14c506@aol.com>
In a message dated 6/8/2003 9:27:14 AM US Mountain Standard Time, costello@mitre.org writes: > I have implemented an OWL API. It comes in two flavors: Java and XSLT. > > Here is the URL: > > http://www.xfront.com/owl/api/ > Nice start! General comments: 1. Needs to be in a package. 2. Should separate these accessor type functions into an interface like this: ------------------------------------------------------------------------------ --------------------- package com.xfront.owl; /** * @author Michael C. Daconta */ public interface OwlAccessor { public String getProperties(String classURI); public String getEquivalentProperties(String propertyURI); public String getSuperClasses(String classURI); public String getPropertyTypes(String propertyURI); public String getClassSpecificPropertyDefinitions(String classURI, String propertyURI); public String getDomain(String propertyURI); public String getRange(String propertyURI); public String getInstances(String classURI); public String getEquivalentClasses(String classURI); } ------------------------------------------------------------------------------ -------------------------------- 3. Use a factory pattern (like DocumentBuilder) to separate the source from the accessor. Then, your implementation, would be either the FileBuilder or FileSource which would return an instance of a Class which implements OwlAccessor. Like this: OwlAccessor accessor = OwlFactory.configure(File f); Which would return your OWL_API class (although this is not a good name for a Class). I would rename your class to something like OwlFileAccessor. 4. Java has a URI class which would is more suitable than Strings because the validity of the URI will be tested by the URI class. I will try and find time to look at each methods parameters and return types to determine if their are better alternatives. Again, good start ... - Mike --------------------------------------------------- Michael C. Daconta Chief Scientist, APG, McDonald Bradley, Inc. www.daconta.net
Received on Sunday, 8 June 2003 12:58:04 UTC