more on - Problems compiling 1b3a under NT 4.0

Thanks to the several people who responded to my original post on this issue.

I too suspected that I had some sort of forward reference problem but given that I'm fuzzy on how projects and sub-projects share symbols, I wasn't sure how to deal with it.

I did find out that if I commented out the line in HTProxy where it references HTAuthFilter, I could, indeed, compile the entire library.  This was Eric's suggestion.  I wasn't really happy with this, though, as it is just plastering over some deeper issue.

Then I tried Abderrezak's suggestion about making wwwapp a sub-project of wwwrules and it worked just as he said.  In this case, I am able to leave the reference to HTAuthFilter in HTProxy and compile the wwwrules sub-project without errors.  In fact, I can now compile the entire project with 0 errors and 13 warnings.

So, my conclusion is that if you have a 'forward reference' situation, you can make the project which will eventually define the needed symbol as sub-project of the project that needs the symbol and thus get the compiler to somehow wait for the later project to get compiled before it uses the necessary symbol.

Abderrezak, can you tell us more about how this really works?  What I just said in the last paragraph looks bogus to me but I can't think of how to explain it any better.

Frystyk, is this problem I've been discussing a known issue or is it something new?

Thanks again to all,

Dennis Gallagher