Re: [Q] C++ Style idea

Sacha writes:

> Some methods affect a whole class rather than just an instance
> of a class. For example, HTNet_setMaxSocket set the maximum
> number of sockets for *all* HTNets (right?). Perhaps we could
> differentiate between class methods and instance methods by
> adding Class to the method name, e.g.
> 	HTNetClass_setMaxSocket
> 	HTRequestClass_setMaxRetry
> I realise that it's pretty clear what is a class method and
> what isn't by checking to see whether it takes a 'me' pointer,
> but I think my idea makes it explicit. It would just be a case
> of a few #defines in a new library (to maintain compatibility
> with existing software).

This is a good idea and if people do not object violently then
it sould be a question of changing a couple of names and adding
some macros. This is for example also what we did in the HTChunk
interface which now have the old interface defined as macros.

PS: As I mentioned in the small announcement of 4.1, I am not in my
office, and I won't be back until late next week... and no - it's
_not_ vacation :-(

PPS: Sacha, a good way of making sure that we receive requests like 
that is to send a copy to the <www-lib-bugs@w3.org> mailing list
which is referenced from the top page of the library.