[Q] C++ Style idea


Some methods affect a whole class rather than just an instance
of a class. For example, HTNet_setMaxSocket set the maximum
number of sockets for *all* HTNets (right?). Perhaps we could
differentiate between class methods and instance methods by
adding Class to the method name, e.g.


I realise that it's pretty clear what is a class method and
what isn't by checking to see whether it takes a 'me' pointer,
but I think my idea makes it explicit. It would just be a case
of a few #defines in a new library (to maintain compatibility
with existing software).

Does anyone have any feelings about this or do I reveal myself
as being a picky git? Perhaps someone resents my attempts to
bring forward the onset of RSI by adding unnecessary chars?