Re: w3c -post

> Manfred Gundel writes:
> > Hi, 
> > 
> > the call to the CommandLineTool w3c
> > 'w3c -post -dest "http://server/cgi-bin/script" "<local_file>"' worked with
> > version 4.0,
> > but it doesn't work with the new release.
> > 
> > I saw that there is a number of entries in the list concerning the
> > ComLineTool and POST,
> > but none of them has been answered.
> > 
> > I would be glad get some feedback on this.
> Henrik F. Nielsen answers:
> It's on the plate but I haven't had any time to get around checking it. Do 
> you have any clues why it doesn't work anymore?
> Any help would be greatly appreciated!
> Thanks,
> ... 

All I can tell you is that you end up with an entry in the server's
log file like this: - - [02/Jul/1996:16:09:15 -0100] "" 400 209
and the error log saying:
[02/Jul/1996:16:09:15 -0100] [OK] [host:] Invalid
request "" (unknown method) (400) ""
(which is probably no surprise ...)

The POST action doesn't work with the Line Mode Browser, too.
I tried to build my own PostWeb object to upload a file but I failed
All I managed was to send along a string saying 'Hello World' using
HTAnchor_setDocument(source, str);
status = HTUploadAnchor((HTAnchor *) source, request,

If anyone has a little example of how to prepare the involved objects
for a successfull call to HTCopyAnchor I it would be very nice if I
could have a look.

I'm sorry that I couldn't do more ...


Manfred Gundel

Received on Tuesday, 2 July 1996 11:12:07 UTC