W3C home > Mailing lists > Public > www-jigsaw@w3.org > March to April 1999

Re: Applets not being served.

From: Benoit Mahe <Benoit.Mahe@sophia.inria.fr>
Date: Thu, 25 Mar 1999 10:29:33 +0100
Message-ID: <36FA01FD.404CBEA6@sophia.inria.fr>
To: Brian Dupras <bdupras@bigfoot.com>
CC: www-jigsaw@w3.org, Aaron Patula <vr5@uswest.net>, Rudi Broos <rudi.broos@alcatel.be>
We forgot to put class extension in the default indexer, so applet
class files are not reachable by default. That's a mistake.
But, you can add it by yourself, please read [1]. You just have to
create a resource called "class" in the default indexer, a FileResource
associated to an HTTPFrame with a content type equals to

This will be added in the next Jigsaw release.

[1] http://www.w3.org/Jigsaw/Doc/User/indexers.html

Regards, Benoit.

Brian Dupras wrote:

> I'm sure this is simply a config problem, but reading the docs and playing
> with JigAdmin hasn't helped (yet).
> I have a simple HTML file and a Java applet in a directory.
> (Jigsaw/WWW/Test/Foo.html and Foo.class)  The HTML file is simply this:
> <HTML>
> <HEAD>
> </HEAD>
> <BODY>
> Testing
> <APPLET  ID="Foo"  code="Foo"  MAYSCRIPT></APPLET>
> </BODY>
> </HTML>
> When I load the file (http://localhost/Test/Foo.html), I get a "class Foo
> not found" error.
> At first I though that adding a "class" extension to the default indexer
> would do the trick, but I still get the same error.
> If I simply load the file locally (E:\Program Files\...\WWW\Test\Foo.html)
> in a browser, the applet loads fine.
> Any suggestions?  Every applet shouldn't need to be in the classpath, right?
> Brian

- Benoît Mahé -------------------------------------------------------
                      World Wide Web Consortium (W3C)
                    Architecture domain - Jigsaw Team

  http://www.w3.org/People/Mahe - bmahe@w3.org - +
Received on Thursday, 25 March 1999 04:29:41 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:26 UTC