W3C home > Mailing lists > Public > www-jigsaw@w3.org > March to April 1999

Re: AW: Problem in accessing GIF files

From: Yves Lafon <ylafon@w3.org>
Date: Wed, 10 Mar 1999 16:37:13 +0100 (MET)
To: Werner Hennrich <weHe@TeleWeb.at>
cc: Www-Jigsaw <www-jigsaw@w3.org>
Message-ID: <Pine.GSO.4.10.9903101624380.7218-100000@tarantula.inria.fr>
On Mon, 8 Mar 1999, Werner Hennrich wrote:

> OK, I have now put one of my own gifs into JigSaw's Icon folder, lauched
> JigSaw and requested http://localhost:8001/Icons/wehe.gif - that worked
> fine. Then came the surprise: http://localhost:8001/Icons (an auto-gnerated
> index, showing all names and images as well) showed up perfectly, while
> http://localhost:8001/Icons/WWW _DID_NOT (showed the names of the gifs but
> was unable to display the images). That seems to be a problem with the
> indexer on the WWW folder...
> I'd say, the objection to using Jigsaw is still up.

All the files stored on the disk are exported the same way, regardless of
their content type. So if you have problem with gifs, you should
experience the same problems with ALL the files exported (FileResource
with an HTTPFrame attached to it). The only difference is in the
content-type added in the headers but that's all. All files are considered
as binary content that feeds a pipe when you are sending them.

Btw, /Icons is just redirected to /icons, and /icons/WWW is indexed like
/icons as the indexer is set only on /icons (then inherited)
You may want to start jigsaw with the -trace option to see the response
sent by the server.

The strange thing is that I never experienced this problem, not on unix
and not on NT (I tried only msie5.0b and ns4.* on the NT box)..

      /\          - Yves Lafon - World Wide Web Consortium - 
  /\ /  \        Architecture Domain - Jigsaw Activity Leader
 /  \    \/\    
/    \   /  \   http://www.w3.org/People/Lafon - ylafon@w3.org    
Received on Wednesday, 10 March 1999 10:37:35 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:26 UTC