Thursday, 29 March 2012
Wednesday, 28 March 2012
Tuesday, 27 March 2012
- Re: Erratum DOM 3 Core: Node interface, prefix attribute
- Erratum DOM 3 Core: Node interface, prefix attribute
Saturday, 24 March 2012
- [Bug 16507] New: Update or remove 1.3 Feature Detection
- [Bug 16506] New: Comments on 1.2 Conformance
Tuesday, 20 March 2012
Friday, 23 March 2012
- [DOM3 Events] key values list
- Re: event.key and event.char for combined key presses (ctrl+b etc)
- [Bug 16493] New: setAttribute(), xmlns, and namespace lookup
- [Bug 16492] New: Use [EnforceRange]?
- [Bug 16491] New: Add simpler and better event registration system
- Re: Optimize setting textContent?
- [Bug 16490] New: Add [ArrayClass] to HTMLCollection?
- [Bug 16489] New: Retrieve element language
- [Bug 16488] New: Consider adding parent() / ancestor() method
- [Bug 16487] New: EventTarget constructor
Thursday, 22 March 2012
- Re: [DOM4] EventTarget as first class citizen
- Re: [dom] DocumentFragment mutations
- Re: [DOM4] EventTarget as first class citizen
- Re: [dom] DocumentFragment mutations
- [Bug 16478] New: Import DOMStringMap from HTML
- [Bug 16477] New: Figure out if we can import event handler attributes from HTML
- [dom] DocumentFragment mutations
Wednesday, 21 March 2012
- [Bug 13843] Define Range mutation for normalize()
- High Resolution Time API and DOM events
- [Bug 16459] getElementsByTagName(qualifiedName) s/qualified/local/
- [Bug 15950] Rename no-quirks mode and limited quirks mode
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- [DOM3 Events] Timing issue of compositionupdate
- [Bug 16285] Default actions section is quite confusing; review and polish
Tuesday, 20 March 2012
- [Bug 16459] New: getElementsByTagName(qualifiedName) s/qualified/local/
- [Bug 16453] Rename "node document"
- [Bug 16453] New: Rename "node document"
- [Bug 16373] replacing a child creates extra mutationrecord
- [Bug 16372] MutationObserver handling is wrong for .textContent
- [Bug 15194] Insertion of a DocumentFragment underspecified
- [Bug 16373] replacing a child creates extra mutationrecord
- [Bug 16373] replacing a child creates extra mutationrecord
- Re: Details of MutationObserver delivery order
- [Bug 16392] MutationObserver invocation order should be fixed at the beginning of each loop
- [Bug 16443] New: Make 3.6 Event exceptions explicitly non-normative
- [Bug 16338] event table forbids e.g. load to dispach on XMLHttpRequest
- [Bug 12958] 'textinput' event should be renamed to 'input'
- [Bug 16408] Support createEvent("Events") -> Event interface
- [Bug 16329] compositionstart should not be cancellable for IME
- [Bug 16333] Exceptions
Monday, 19 March 2012
- [Bug 16425] MutationObserver::observe/disconnect should return mutationobserver itself
- [Bug 14050] Need a spec for UIEvent constructor
- [Bug 14055] Need a spec for CompositionEvent constructor
- [Bug 14052] Need a spec for KeyboardEvent constructor
- [Bug 14054] Need a spec for TextEvent constructor
- [Bug 14053] Need a spec for WheelEvent constructor
- [Bug 14051] Need a spec for MouseEvent constructor
- [Bug 16333] Exceptions
- [Bug 16435] 'this' value in MutationObserver callback should be MutationObserver object by default
- [Bug 16435] 'this' value in MutationObserver callback should be MutationObserver object by default
- [Bug 16435] 'this' value in MutationObserver callback should be MutationObserver object by default
- [Bug 16435] New: 'this' value in MutationObserver callback should be MutationObserver object by default
- [Bug 16431] Ambiguous definition
- [Bug 16431] New: Ambiguous definition
- [Bug 16426] Non-existent reference to a 'child' in the pre-remove algorithm
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- [Bug 16426] New: Non-existent reference to a 'child' in the pre-remove algorithm
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
Sunday, 18 March 2012
- [Bug 16425] MutationObserver::observe/disconnect should return mutationobserver itself
- [Bug 16425] New: MutationObserver::observe/disconnect should return mutationobserver itself
- [Bug 16424] Invalid return value specified for the pre-instert algorithm
- [Bug 16424] New: Invalid return value specified for the pre-instert algorithm
- [Bug 16285] Default actions section is quite confusing; review and polish
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- Re: [DOM3 Events] Error between float vs. double of WheelEvent
- [DOM3 Events] Error between float vs. double of WheelEvent
- [DOM3 Events] Issues of target of composition events
Saturday, 17 March 2012
- [Bug 16356] Typo "originalted"
- [Bug 16355] Typo in delta* properties of Wheel Event Types section
- [Bug 16333] Exceptions
- [Bug 16330] data of compositionstart dead key examples are wrong
- [Bug 16285] Default actions section is quite confusing; review and polish
Friday, 16 March 2012
- Any thoughts on this?
- [Bug 16409] New: DOM4: Consider LeafNode interface which Node inherits from
- [Bug 16408] New: Support createEvent("Events") -> Event interface
Thursday, 15 March 2012
Wednesday, 14 March 2012
- [Bug 16373] New: replacing a child creates extra mutationrecord
- [Bug 16372] New: MutationObserver handling is wrong for .textContent
Tuesday, 13 March 2012
- [Bug 16357] New: Avoid proliferating init*Event methods in preparation for Event constructors
- [Bug 16356] New: Typo "originalted"
- [Bug 16355] New: Typo in delta* properties of Wheel Event Types section
- [Bug 16354] New: Update reference to Document.getSelection()
- [Bug 16353] Use udpated WebIDL syntax
- [Bug 16353] New: Use udpated WebIDL syntax
- [Bug 16352] New: Add normative reference to defaultView
- [Bug 16350] Fix occurances of RFC2119 terms in notes
- [Bug 16350] New: Fix occurances of RFC2119 terms in notes
- [Bug 16348] New: "CSS layout box" definition missing
- [Bug 16338] event table forbids e.g. load to dispach on XMLHttpRequest
Monday, 12 March 2012
- [Bug 16339] New: Some comments on Basic Event Interfaces
- [Bug 16338] event table forbids e.g. load to dispach on XMLHttpRequest
- [Bug 16338] New: event table forbids e.g. load to dispach on XMLHttpRequest
- [Bug 16337] New: initEvent()
- [Bug 16336] New: defaultPrevented and preventDefault() conflict
- [Bug 16335] New: undefined attribute values
- [Bug 16333] New: Exceptions
- [Bug 16332] New: stop propagation and canceled flags
- [Bug 16330] New: data of compositionstart dead key examples are wrong
- [Bug 16329] New: compositionstart should not be cancellable for IME
- [Bug 15201] HTMLCollection.item(string) should act like namedItem(string)
Sunday, 11 March 2012
Saturday, 10 March 2012
- Forgery Alert [Was: Re: Introduction]
- [Bug 15330] MouseWheel.initWheelEvent error
- [Bug 16275] [DOM L3 Events] Contradition statement regarding keyboard events in the CompositionEvents section
- [Bug 15921] The WheelEvent.initWheelEvent modifiersListArg parameter should be documented
Friday, 9 March 2012
- RE: DOM3 Events - additional editing help to move the spec forward
- [Bug 16285] New: Default actions section is quite confusing; review and polish
- Re: DOM3 Events - additional editing help to move the spec forward
Thursday, 8 March 2012
- DOM3 Events - additional editing help to move the spec forward
- [Bug 16275] New: [DOM L3 Events] Contradition statement regarding keyboard events in the CompositionEvents section
Wednesday, 7 March 2012
Tuesday, 6 March 2012
Monday, 5 March 2012
Saturday, 3 March 2012
Thursday, 1 March 2012
- [DOM3 Events] initMouseEvent() and initWheelEvent() don't take same arguments
- [Bug 14569] URL object should not return DOMTokenList
- [Bug 14569] URL object should not return DOMTokenList
- [Bug 14569] URL object should not return DOMTokenList
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: "DOM4 Events" Proposal (was: Spec proposals for Event constructors)
- Re: [DOM4] EventTarget as first class citizen
Wednesday, 29 February 2012
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- [Bug 16140] DOM should keep a list of MutationObservers in creation order
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
- Re: [DOM4] EventTarget as first class citizen
Monday, 27 February 2012
- [Bug 16140] New: DOM should keep a list of MutationObservers in creation order
- [Bug 16092] MutationObserver.disconnect() should cancel any pending deliveries
- Re: [DOM4] EventTarget as first class citizen
Friday, 24 February 2012
Thursday, 23 February 2012
- [Bug 16092] New: MutationObserver.disconnect() should cancel any pending deliveries
- Re: [dom] Introduction to Events
- Re: [dom] Introduction to Events
- [dom] Introduction to Events
Wednesday, 22 February 2012
Tuesday, 21 February 2012
Monday, 20 February 2012
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Re: Default value of cloneNode() parameter
- Default value of cloneNode() parameter
- Re: [progress-events] Loading, Interactive and Error states for downloaded resources -- fallback content
Sunday, 19 February 2012
Saturday, 18 February 2012
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
Friday, 17 February 2012
- Re: [dom] mutation observer follow up
- Re: [dom] mutation observer follow up
- Re: [dom] mutation observers and HTML
- Re: [dom] mutation observer follow up
- Re: [dom] mutation observers and HTML
- Re: [dom] mutation observers and HTML
- Re: [dom] mutation observer follow up
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- [Bug 15609] Returning a NodeList from getElementsByTagName and company is likely not web-compatible as things stand
- Re: [dom] mutation observers and HTML
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- [Bug 13375] Don't define things in terms of attributes
- [Bug 15695] Should MutationCallback be a callback *interface*?
- [dom] mutation observers and HTML
- [dom] mutation observer follow up
Thursday, 16 February 2012
Wednesday, 15 February 2012
Tuesday, 14 February 2012
Monday, 13 February 2012
Friday, 10 February 2012
Thursday, 9 February 2012
- RE: What is the plan for DOM3 Events spec?
- What is the plan for DOM3 Events spec?
- Re: Optimize setting textContent?
- Re: Optimize setting textContent?
Wednesday, 8 February 2012
- Re: Optimize setting textContent?
- Re: Optimize setting textContent?
- Re: Optimize setting textContent?
- Re: Optimize setting textContent?
- Re: Optimize setting textContent?
- Re: Optimize setting textContent?
- Optimize setting textContent?
Tuesday, 7 February 2012
- Re: Undocumented paramter
- [Bug 15921] New: The WheelEvent.initWheelEvent modifiersListArg parameter should be documented
Monday, 6 February 2012
Friday, 3 February 2012
- Re: [progress-events] Loading, Interactive and Error states for downloaded resources -- fallback content
- Re: [progress-events] Loading, Interactive and Error states for downloaded resources -- fallback content
- [progress-events] Loading, Interactive and Error states for downloaded resources -- fallback content
Thursday, 2 February 2012
- Re: DOM Level 2 HTML obsolete?
- DOM Level 2 HTML obsolete? (Re: DOM Level 2 HTML: Note about onsubmit is misplaced in HTMLFormElement spec (in enctype attribute rather than in submit method))
Tuesday, 31 January 2012
Monday, 30 January 2012
- RE: Rename "DOM4 Events"
- Re: "DOM4 Events" Proposal (was: Spec proposals for Event constructors)
- Rename "DOM4 Events"
Saturday, 28 January 2012
Friday, 27 January 2012
- Re: "DOM4 Events" Proposal (was: Spec proposals for Event constructors)
- Re: "DOM4 Events" Proposal (was: Spec proposals for Event constructors)
Thursday, 26 January 2012
- Re: "DOM4 Events" Proposal (was: Spec proposals for Event constructors)
- [DOM3Events] KeyboardEvent key and char clarification
- Re: "DOM4 Events" Proposal (was: Spec proposals for Event constructors)
Wednesday, 25 January 2012
Tuesday, 24 January 2012
- [Bug 15695] New: Should MutationCallback be a callback *interface*?
- Re: [DOMCore] createElement() and HTML-specific element interfaces
Monday, 23 January 2012
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
- Re: DOM Level 2 HTML: Note about onsubmit is misplaced in HTMLFormElement spec (in enctype attribute rather than in submit method) (was Re: Minor formatting error in HTMLFormElement spec)
Saturday, 21 January 2012
Friday, 20 January 2012
Wednesday, 18 January 2012
- [Bug 15609] New: Returning a NodeList from getElementsByTagName and company is likely not web-compatible as things stand
- Re: [dom] Should the return values of getElementsByClassName/TagName/TagNameNS be HTMLCollection
Tuesday, 17 January 2012
Monday, 16 January 2012
- [Bug 15584] New: Test function myInsertNode() not setting end point according to spec.
- [Bug 15583] New: BAD_BOUNDARYPOINTS_ERR no longer used for Range
Saturday, 14 January 2012
- Re: event.key and event.char for combined key presses (ctrl+b etc)
- [Bug 15555] New: Figure out which feature strings should be supported
Friday, 13 January 2012
- Re: Fwd: DOM event detection
- [Bug 15544] New: Wrong node used for range adjustment in the remove mutation