[Fwd: OpenMotif not recognized]

(I assume that i had to be subscribed to get this thru to the list, as
the below is still not listed at
http://lists.w3.org/Archives/Public/www-amaya/2001JulSep/. I'm now
subscribed; hopefully this'll work.)

Forwarded message 1

  • From: George Herson <gherson@snet.net>
  • Date: Fri, 13 Jul 2001 10:39:33 -0400
  • Subject: OpenMotif not recognized
  • To: www-amaya@w3.org
  • Message-ID: <3B4F0825.2E52EAB@snet.net>

I'm attempting to compile Amaya 5.1 on my RedHat Linux v6.2 (2.2.14-5.0
kernal).  This is my system's first attempt at compiling Amaya;
previously I installed Amaya via rpm.

To satisfy Amaya's Motif prerequisite, I downloaded openmotif 2.1.30
(openmotif-2.1.30-4_MLI.i386.rpm and
openmotif-devel-2.1.30-4_MLI.i386.rpm from
and installed these w/o error.

# ../configure 
from LINUX-ELF directory still ends with:
'Motif seems not installed on this machine
Amaya need Motif 1.2 or 2.0
Now start "make all" (GNU make preferably) to build the bianries'.

So configure doesn't seem to recognize my OpenMotif.

I also tried ../configure --with-gtk because
"--with-gtk                build Amaya using GTK, instead of Motif"
makes it sound like Motif might not be needed. But the error's the same.

After i installed the openmotif-devel-2.1.30-4_MLI.i386.rpm,
# make all, instead of failing quickly with complaints of not finding,
eg, "xm/ScrollBar.h", lasted ~10min. But it too eventually died, ending

dialogapi.o(.text+0x70f0): undefined reference to `_XmStrings'
dialogapi.o(.text+0x7195): undefined reference to `_XmStrings'
dialogapi.o(.text+0x71a5): undefined reference to `_XmStrings'
dialogapi.o(.text+0x71b2): undefined reference to `_XmStrings'
keyboards.o(.text+0x6b7): undefined reference to `_XmStrings'
keyboards.o(.text+0x739): undefined reference to `XmCreateDrawnButton'
keyboards.o(.text+0x756): undefined reference to `_XmStrings'
keyboards.o(.text+0x772): undefined reference to `_XmStrings'
collect2: ld returned 1 exit status
make[1]: *** [../bin/amaya] Error 1
make[1]: Leaving directory `/usr/local/Amaya/LINUX-ELF/amaya'"

I went back to the instructions. 
http://www.w3.org/Amaya/User/Autoconf.html says "4. Edit the
Options.orig file as needed".  I think that should be the "Options"
file, not "Options.orig".  I edited the Options file to add
(MOTIF_LIBRARIES=/usr/X11R6/lib wasn't necessary as that directory is
already showing up with make all's gcc -L).  This didn't seem to help,


thank u,

Received on Friday, 13 July 2001 17:15:50 UTC