W3C home > Mailing lists > Public > www-amaya-dev@w3.org > June 2006

Re: bug-reports amaya 8.51 and 9.51

From: Irene Vatton <Irene.Vatton@inrialpes.fr>
Date: Fri, 9 Jun 2006 09:04:08 +0200
To: "Regis Boudin" <regis@boudin.name>
Cc: "Rigo Wenning" <rigo@w3.org>, www-amaya-dev@w3.org
Message-Id: <200606090904.08101.vatton@inrialpes.fr>

Hi Regis and Rigo,

I mouved to www-amaya-dev@w3.org as it's probably too technical for usual 

On Thursday 08 June 2006 17:14, Regis Boudin wrote:
> Irene Vatton said:
> >> Well, this is probably a bug in the Mesa/X/ati DRI driver, according to
> >> one of the Mesa maintainers for Debian.
> >
> > This is exactly the reason why we distribute by default a version with a
> > soft GL implementation.
> The problem is that there seem to be another bug somewhere between
> wxWidgets and X withe software GL implementation as well.

Yes, there are also some bugs in the soft Mesa implementation. I detected some 
problems with some redisplays.

> >> Now, I don't understand things anymore. It doesn't work for me. Maybe
> >> because I didn't have the DRI enable when I tested yesterday evening.
> >
> > The version from the W3C server doesn't use shared  redland, wxWidgets,
> > libGL, and libGLU libraries.
> Agreed. Though it doesn't explain why it crashed for me.

That's very annoying. Perhaps "strace" could help.

> >> It's slightly more complicated. The Debian one is linked against the
> >> shared libGL and libGLU, rather than the one provided in the source
> >> tarball. The problem is, there seem to be a bug somewhere in wxWidgets
> >> and/or Mesa, though I haven't managed to find where exactly.
> >> Before someone asks, I tried to build with static wxWidgets and Mesa
> >> from
> >> the source, and I still had the error.
> >
> > Did you link with local wxWidgets and Mesa libraries?
> I tried different variants. both shared, shared Mesa, both static (linked
> against the source from the tarball), and it always crashes for me. I
> could notice that my patches didn't make it possible to use a shared
> wxWidgets but a local Mesa, which would probably be quite nasty anyway.

Perhaps the new build keeps previous options. When I want to change this kind 
of options, I destroy the object directory and I regenerate a new one.
Our experience shows that the majority of problems comes from libGL and libGLU 
libraries, but I have no more explanation.

> One fairly common thing however is that everybody reporting the bug seems
> to be using and ATI driver... I have yet to hear from someone using a
> different graphic card. I also know it works with the nVidia proprietary
> driver, which uses its own GL library.
> > The best would be to have GL hardware implementations fixed.
> Definitely. I think everyone agrees with that. Unfortunately, it's not
> something I know much about.
> > But meanwhile Rigo, I don't know if it works, you could test if the
> > debian package generated by Regis works with GL_ACCELERATED=no in the
> > file .amaya/thot.rc
> > I know that this GL_ACCELERATED variable must be set to "no" on a large
> > set of Windows platforms to prevent important troubles.
> This variable is only valid on Windows, if I remember what I saw when
> digging through the wxWidgets source.

You're probably right. Stéphane Gully wrote this patch in the Windows 
wxWidgets version.

> Regis

Irène Vatton                     INRIA Rhône-Alpes
INRIA                               ZIRST
e-mail: Irene.Vatton@inria.fr       655 avenue de l'Europe
Tel.: +33 4 76 61 53 61             Montbonnot
Fax:  +33 4 76 61 52 07             38334 Saint Ismier Cedex - France
Received on Friday, 9 June 2006 07:05:59 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:31:08 UTC