W3C home > Mailing lists > Public > w3c-rdfcore-wg@w3.org > June 2001

Re: rdfc25May.n3 testcase

From: <jos.deroo.jd@belgium.agfa.com>
Date: Fri, 1 Jun 2001 14:47:01 +0100
To: connolly@w3.org
Cc: w3c-rdfcore-wg@w3.org, timbl@w3.org
Message-Id: <OF031A84D9.0A772F60-ON41256A5E.00499D9B@bayer-ag.com>

DanC wrote [...]
> It turned out to be operator error. After fixing
> some relative references and such, I'm able to
> copy rdfc25May.n3 to ,xx.n3 and get cwm to --think
> about this:
>   @prefix log: <http://www.w3.org/2000/10/swap/log#>.
>   @prefix : <#>.
>   { [ is log:resolvesTo of <rdfc25May.n3> ] log:includes
>     [ is log:resolvesTo of <,xx.n3> ] } log:implies { :test1 a :Success
> }.
> for a while; after 10 or 20 seconds, it concludes
>    :test1 a :Success.
> Then if I edit ,xxx.n3 and add one more statment, cwm no
> longer --think's that rdfc25May.n3 includes ,xx.n3.

I tried it also and it works very well (but I didn't
use the comma in the name, maybe a DOS problem?)
and on my laptap it's just a couple of seconds.
I spent a couple of hours last night to find bugs
(swapping statements, changing """ quoted text, using
{} examples (that sometimes takes a long time e.g.
is still running (i hope not in a loop) and that
since the last 5 hours)) and it always worked!
On the other end, I found a lot problems in Euler
but it's now going a lot better after that we
introduced a -core mode which is basically disabling
some parts in the inference engine (version 26.062)

Jos De Roo, AGFA http://www.agfa.com/w3c/jdroo/
Received on Friday, 1 June 2001 08:47:53 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 20:24:01 UTC