Re: Implementation of Murray's proposal

/ Alessandro Vernet <> was heard to say:
| On 12/19/06, Norman Walsh <> wrote:
|> I decided to use the element names 'pipe', 'document', and 'inline'
|> to represent the three possible kinds of bindings.
| Norm, taking off your editor's hat for a second, since you are deep
| into this, what is your feeling?

I'm undecided. The nested elements design feels cleaner in some ways,
but it's awfully expensive in terms of readability:

  <p:step type="p:validate" name="s2">
    <p:input port="document" step="s1" source="result"/>
    <p:input port="schema" step="fig1" source="schemaDoc"/>


  <p:step type="p:validate" name="s2">
    <p:input port="source">
      <p:pipe step="s1" port="result"/>
    <p:input port="schema">
      <p:pipe step="fig1" port="schemaDoc"/>

Of course, that's in the eye of the beholder to a certain extent.
And if we imagine that the eventual defaulting story makes most of
this markup unnecessary anyway...

| The alternate syntax certainly comes out as a good design. But it is
| also a heavier syntax. Is the current syntax so unclear that we need
| to always add nested elements? Do we need to create combined sequences
| of documents (say with part coming from another step  and part inline)
| so badly that we need to make the syntax of every <p:input> and
| <p:output> heavier? I remained unconvinced that the answer to any of
| those two questions is a clear yes.

As for the latter question, I think the answer is no. The ability to
create sequences of documents inline is nice, but it can easily be
accomplished with a standard component:

<p:step type="p:sequence">
  <p:input port="name1" href="..."/>
  <p:input port="name2" step="..." source="..."/>
  <p:input port="name3"><doc/></p:input>

                                        Be seeing you,

Norman Walsh
XML Standards Architect
Sun Microsystems, Inc.

Received on Thursday, 21 December 2006 14:41:44 UTC