some more thoughts

a few more thoughts;

a) declare-step and improving reuse

Take the following example;

<p:declare-step type="p:rename">
     <p:input port="source"/>
     <p:output port="result"/>
     <p:option name="match" required="yes"/>
     <p:option name="name" required="yes"/>
</p:declare-step>

would be nice to be able to define default values for a declared step ala.

<p:declare-step type="my:rename" inherit="p:rename">
     <p:option name="name" required="yes" value="test.txt"/>
</p:declare-step>


b) versioning pipeline libraries and steps

sometimes versioning via namespace declarations makes it hard to
maintain existing code, as one has to go through everything and change
declared namespaces....we might find it useful to provide some
mechanism here...I know I am opening up a can of worms, so let me
present something simple.

<p:declare-step type="my:rename" inherit="p:rename" version="1">
     <p:option name="name" required="yes" value="test.txt"/>
</p:declare-step>

<p:declare-step type="my:rename" inherit="p:rename" version="2">
     <p:option name="name" required="yes" value="test.txt"/>
</p:declare-step>

this lets me use both versions of my:rename in the same pipeline if we
had matching version attribute to choose from....in this situation we
might even make an analogy with XSLT mode attribute...which has been
ab/used for such things.

perhaps more appropriate is to allow a version attribute on the
pipeline library itself, but then we should consider the maintenance
aspect to this....e.g. the need to change import to use a different
library...perhaps we just give a version to pipeline library element
and allow multiple named libraries to be named in the same import
using perhaps a <p:pipeline-libraries/> element?

c) p:journal feels like p:log to me

d) any chance of a default p:wait step that just does nothing for a
period of time?

more thoughts coming.

cheers, Jim Fuller

ps: ok a silly request now....well if one never asks.....XProc has
lots of the character  p's in the language (pipes, input, output,
namespace prefix is a p, etc): I know this is syntax, but I have
always seen this type of thing as lowering readibility (might be my
demented mind)...

perhaps you should consider some aliases for input and output elements
(e.g. in and out) and just use x for namespace prefix I think it would
improve readability. Don't waste anytime responding to this, silence
will do as a vote in the negative.

Received on Thursday, 7 June 2007 19:47:58 UTC