W3C home > Mailing lists > Public > whatwg@whatwg.org > October 2013

Re: [whatwg] Proposal: Adding methods like getElementById and getElementsByTagName to DocumentFragments

From: Simon Pieters <simonp@opera.com>
Date: Mon, 14 Oct 2013 22:38:33 +0200
To: "Glenn Adams" <glenn@skynav.com>
Message-ID: <op.w4yoyjgfidj3kv@simons-macbook-pro.local>
Cc: whatwg <whatwg@lists.whatwg.org>, Boris Zbarsky <bzbarsky@mit.edu>, Glenn Maynard <glenn@zewt.org>
On Thu, 10 Oct 2013 17:52:49 +0200, Glenn Adams <glenn@skynav.com> wrote:

>> You'd actually write "CSS.escape", so that's basically the longer,
>> different name. Is that sufficient?
> I don't want to bikeshed over this, but I was thinking of perhaps
> serializeIdent(), or escapeIdent().

The API is intended to be used for escaping CSS strings too. Also, I think  
most Web developers don't think in terms of CSS tokens.

Serialize seems a bit wrong since the input isn't an object.

Simon Pieters
Opera Software
Received on Monday, 14 October 2013 20:39:03 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 17:00:11 UTC