W3C home > Mailing lists > Public > whatwg@whatwg.org > October 2013

Re: [whatwg] Proposal: Adding methods like getElementById and getElementsByTagName to DocumentFragments

From: Simon Pieters <simonp@opera.com>
Date: Thu, 10 Oct 2013 16:12:07 +0200
To: "Glenn Adams" <glenn@skynav.com>
Message-ID: <op.w4qsehzyidj3kv@simons-macbook-pro.local>
Cc: whatwg <whatwg@lists.whatwg.org>, Boris Zbarsky <bzbarsky@mit.edu>, Glenn Maynard <glenn@zewt.org>
On Thu, 10 Oct 2013 15:41:41 +0200, Glenn Adams <glenn@skynav.com> wrote:

>> I've added CSS.escape(foo).
>>
>
> Given the existence of Window.escape(), i.e., the JS escape(string)
> function property of the Global object, I wonder if choosing a longer,
> different name would be better to avoid confusion.

You'd actually write "CSS.escape", so that's basically the longer,  
different name. Is that sufficient?

-- 
Simon Pieters
Opera Software
Received on Thursday, 10 October 2013 14:12:41 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 17:00:11 UTC