[whatwg] rename CanvasPixelArray

On Mon, 4 May 2009, Anne van Kesteren wrote:
> On Fri, 01 May 2009 01:10:19 +0200, Ian Hickson <ian at hixie.ch> wrote:
> > I haven't renamed it. I don't think it's a big deal to introduce other
> > interfaces that look the same but with different names, if we need to.
> I agree that's not a problem, but the asymmetry between ImageData and 
> CanvasPixelArray would be nice to avoid. (I'd be fine with renaming 
> ImageData to CanvasData as well.)

I agree with your sentiment, but I think it'd probably be better to just 
suck it up this time and not worry about it. Let me know next time I 
invent an inconsistently named API before there are implementations. :-)

Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

Received on Friday, 5 June 2009 16:20:56 UTC