[whatwg] <video> element proposal

H?kon Wium Lie:
> Also sprach Bjoern Hoehrmann:
>
>>   | SMIL           | SVG             | IE              | "WHATWG"
>>     beginElement() | beginElement()  | beginElement()  | play()
>>     endElement()   | endElement()    | endElement()    | stop()
>
> I personallay think play, stop and pause are better names.

They are better names, but that does not necessarily mean they are the
better choices. On the other hand all that Bj?rn's scenario requires are
some simple wrapper methods, as far as I understand. Actually one could
provide (almost) all this functionality with just one overload method,
e.g.:

  playback()            // toggle speed between 0 and 1 or stored value
  playback(float speed) //      speed ==  1: play (forward)
                        //      speed ==  0: pause, still
                        //      speed == -1: play backward, reverse
                        //     |speed| >  1: rewind / fast-forward
                        // 0 < |speed| <  1: slow motion
  playback(float speed, int av)
                        // av == 0: no image, no sound
                        // av == 1: image, no sound (mute)
                        // av == 2: sound, no image ("radio mode")
                        // av == 3: image and sound
                        // av == 4: subtitles ...
  playback(float speed, int av, long position)
                        // (0, 0, 0): stop ...

With playlists (or subtracks / chapters) you would need skip (previous;
next).
Eject is probably only for physical media, but record, close, open, save
and the combinations close+open, save+close, save+close+open might be
needed sometime.
I digress.

|video| should be used to embed audio files and streams, too, because in
practice it is a superset.

> Even if it turns out to be impossible to use open codecs in IEx,
> people should still be encouraged to use open codecs.

The several MPEG audio and video codecs, VC-1 and probably others are
open, too, but they are not free to use, i.e. neither for encoding nor for
decoding, at least as far as I know. What do we want: an open
specification, free encoders and/or free decoders?

On an unrelated matter that is discussed nearby, couldn't UAs simply (be
allowed or required to) map |video| to |object| with |type| set to |video|
(or vice versa)?
<http://lists.whatwg.org/htdig.cgi/whatwg-whatwg.org/2006-November/007600.html>

PS: Does someone know whether there is a formal standard for media player
symbols (and thus functions)? I didn't find one, although "standard
symbols" seems a frequent term in the area.

Received on Saturday, 17 March 2007 15:00:08 UTC